tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Longley, Andrew" <andrew.long...@mindflow.com>
Subject RE: Tomcat4.1.14 not working as a NT service??
Date Thu, 15 May 2003 14:01:58 GMT
Bikash,

Besides the other poster who suggested you look at the permission level
of the user you are running the service as, can you verify that you have
included all the classes you need in your classpath?  And that you have
included any additional Windows dlls and so forth in the path?
Regarding the classpath, there is doco on the classloader which
specifies locations that Tomcat automatically polls for jar files and
classes.  If you have classes or jars in other locations, or that are
not of type .class or .jar, you may need to add them explicitly to the
-Djava.class.path parameter.  If you have additional Windows dlls, you
can specify a -path parameter and include them.  These are generally the
reasons I've found that Tomcat as a service does not run properly, when
running from the command line works fine.  I don't believe Tomcat as a
service does not inherit any user classpath or path variables.  If in
doubt, add them in, and see if it helps.

And you don't need to keep uninstalling and reinstalling the service.
You can edit the service in the registry, if you're careful.

Regards,
Andrew

-----Original Message-----
From: Bikash Paul [mailto:bikashpaul_2001@yahoo.com] 
Sent: Wednesday, May 14, 2003 11:42 PM
To: Tomcat Users List
Subject: Tomcat4.1.14 not working as a NT service??

Hi all friends,

IAM POSTING THIS QUERY AGAIN,HOPE SOMEONE HELP ME

I am running Tomcat4.1.24 as a NT service.And I have
created it through below batch file:-

tomcat -install "Apache Tomcat"
"C:\jdk1.3.0_02\jre\bin\classic\jvm.dll" -Xmx256m
-Xms128m
-Djava.class.path="d:\Tomcat\jakarta-tomcat-4.1.24\bin\bootstrap.jar"
-Dcatalina.home="d:\Tomcat\jakarta-tomcat-4.1.24"
-start org.apache.catalina.startup.BootstrapService
-params start -stop
org.apache.catalina.startup.BootstrapService -params
stop -out
"d:\Tomcat\jakarta-tomcat-4.1.24\logs\stdout.log" -err
"d:\Tomcat\jakarta-tomcat-4.1.24\logs\stderr.log"

And it also created service on my WinNT4.0 server
successfully.And I have also tested it by opening the
home page of Tomcat server on IE by typing in address
bar (http://127.0.0.1:8080) and also shows me the home
page successfully.But my problem is when I start my
application for uploading files then Tomcat server not
working(means not writing file on destination).My
application is a Uploading software for transfering
files from one destination to another and I have used
swing for front end(for reading files) and for back
end I have used servlet(for writing files).But when I
use Tomcat as a stand alone not as NT service then it
is working fine.Can any one plz guide me how I can
slove my problem.Eagerly waiting for reply.

Regards
Bikash





__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message