tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Peterson <apeter...@vasoftware.com>
Subject Re: newline in http header
Date Fri, 23 May 2003 18:10:07 GMT
On Thu, May 22, 2003 at 10:34:29PM -0700, John Corrigan wrote:
> What version of Apache are you using as a proxy and on what OS?

Apache 1.3.26-1.1  on debian stable.  I was previously running an older
version of apache that was exhibiting the same problems...  Do you think
it might be resolved with a different version of apache?

Thanks, 


> -----Original Message-----
> From: Aaron Peterson [mailto:apeterson@vasoftware.com]
> 
> Hello:
> 
> I am having an odd problem when using tomcat in conjunction with a reverse
> proxy (apache mod_proxy, and mod_rewrite).  I have been using mod_rewrite
> successfully for almost two years as a reverse proxy for our network.  The
> problem is that when I use it to view a tomcat server, I get a newline in
> the http header, and it shows the last part of the headers in the browser,
> and screws up the formatting.
> 
> The part that seems even more odd, is that I see a few random hex numbers in
> the html output, one after the headers (in one case, 2f0), and one at the
> end of the page (in one case, 0).
> 
> I can reproduce this on several tomcat servers, with different applications
> installed (including jfreechart).  This behaviour happens even on a straight
> html page (within tomcat).
> 
> I tried using squid instead of apache for a proxy, and it did not have these
> problems, but the reverse proxy support in squid is not complete, and is in
> beta.
> 
> I am using tomcat 4.1, and apache 1.3.26-1.1 on debian.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message