tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhishek" <absri...@cisco.com>
Subject RE: WebappClassLoader: Lifecycle error : CL stopped
Date Tue, 27 May 2003 13:43:44 GMT
No, I'm not updating the classes/jars. I've observed this error for classes
other than in tibco jar. It seems that classloader is breaking at some
place. Sometimes it gives the error NoClassDefFoundError for the classes in
the same package.

Here is the trace:
WebappClassLoader: Lifecycle error : CL stopped
java.lang.NoClassDefFoundError: com/tibco/tibrv/TibrvMsg
        at myapp.EventWatch.onMsg(EventWatch.java:264)
        at com.tibco.tibrv.TibrvEvent.invoke(TibrvEvent.java:160)
        at com.tibco.tibrv.TibrvImplQueueC.natDispatch(Native Method)
        at com.tibco.tibrv.TibrvImplQueueC.dispatch(TibrvImplQueueC.java:44)
        at com.tibco.tibrv.TibrvQueue.dispatch(TibrvQueue.java:301)
        at myapp.EventMonitor.run(EventMonitor.java:284)
        at java.lang.Thread.run(Thread.java:566)


> -----Original Message-----
> From: Johannes Lietz [mailto:johannes.lietz@antwerpes.de]
> Sent: Tuesday, May 27, 2003 6:54 PM
> To: Tomcat Users List
> Subject: Re: WebappClassLoader: Lifecycle error : CL stopped
>
>
> Abhishek, are you updating your classes/jars?
>
> I sometimes get this error when I update classes in a running webapp.
> The WebappClassLoader then recognizes the modification and tries to
> reload the app, but it gets an error because some classes are missing
> maybe because they are still beeing copied.
>
>
> On Dienstag, Mai 27, 2003, at 02:59  Uhr, Roberts, Eric wrote:
>
> > Hi,
> >
> > You are running Tibco Rendezvous and Tomcat.
> >
> > Are you invoking tibco messaging from a servlet?
> >
> > Where are your tibco jars?
> >
> > Tibco normally requires a whole load of specially set environment
> > variables and its own classpath.
> >
> > Can you give us some more information as to what your configuration
> > is/what you are attempting to do.
> >
> > -----Original Message-----
> > From: Abhishek [mailto:absrivas@cisco.com]
> > Sent: 27 May 2003 14:03
> > To: tomcat-user@jakarta.apache.org
> > Subject: WebappClassLoader: Lifecycle error : CL stopped
> >
> >
> >
> >  I am using tomcat 4.1.18 and randomly getting the following error.
> >
> >  **************************************************************
> >  WebappClassLoader: Lifecycle error : CL stopped
> >  java.lang.NoClassDefFoundError: com/tibco/tibrv/TibrvMsg
> >  *************************************************************
> >
> >  Is it a known issue that tomcat's classloader is not able to
> >  locate the class even if the classpath is set properly. This
> >  error comes randomly and once it starts coming it can not be fixed.
> >  Will appreciate if anyone can provide the pointers.
> >
> >  Thanks,
> >  Abhishek
> >
> >
> >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message