tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terje Hopsø <tehos...@online.no>
Subject RE: Problem with FORM POST and servlet 4.1.24 SOLVED!!
Date Fri, 02 May 2003 13:28:15 GMT
I had generated a beanInfo.java from Jbuilder. This was done before I
inserted the new fields. This file seems to override the servlet and after
removing it or regenerating it works fine.

Jbuilder generated the servlet. But generating it manually put me on the
track since it worked fine doing that.

But so many wasted hours.  Arghh...

Thanks for giving me tips for solving the problem.

- Terje

-----Original Message-----
From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
Sent: 2. mai 2003 15:15
To: Tomcat Users List
Subject: RE: Problem with FORM POST and servlet 4.1.24



Howdy,
A couple of things to check:

- In your servlet, print out the parameter map (request.getParameterMap) to
a log or something so that you can see they keys/values.
- Enable the AccessLogValve so that you can verify the request URL as tomcat
receives it.

Yoav Shapira
Millennium ChemInformatics


>-----Original Message-----
>From: Terje Hopsø [mailto:tehosubs@online.no]
>Sent: Friday, May 02, 2003 8:31 AM
>To: 'Tomcat Users List'
>Subject: Problem with FORM POST and servlet 4.1.24
>
>Hello,
>
>I have a form where I have several input fields which will be sent to a
>servlet which contains setXXXX and getXXXX for each field.
>
>I tested first with three fields and got them to work fine. Then I added
>nine more. Not one of these new fields are calling the set-function for
>setting the value. Only the three first that was working at the first test.
>I changed to GET method and I can see all parameters are sent.
>
>The parameters for the three fields that are working mixed within the
>parameter string:
>http://ppcterje:8080/regres/regresultat.jsp?navn=XX
><http://ppcterje:8080/regres/regresultat.jsp?navn=XX&sted=&dato=&tid=&ligg=
>1
>&sta=2&kne=3&kls=6&Grl=4&hsk=10&omg=5&msk=15&submitButtonName=Send+resultat
>>
>&sted=&dato=&tid=&ligg=1&sta=2&kne=3&kls=6&Grl=4&hsk=10&omg=5&msk=15&submit
>B
>uttonName=Send+resultat
>
>It is the parameter ligg, sta and kne that is working.
>
>Any idea?
>
>- Terje



This e-mail, including any attachments, is a confidential business
communication, and may contain information that is confidential, proprietary
and/or privileged.  This e-mail is intended only for the individual(s) to
whom it is addressed, and may not be saved, copied, printed, disclosed or
used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the
sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message