tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Warren Sweetman" <warren.sweet...@legalservices.gov.uk>
Subject RE: tomcat IIS configuration please help
Date Tue, 01 Apr 2003 16:44:30 GMT
Yes I have spent a few hrs checking up that I had done what I was supposed to do.   I have
followed the small bits of instruction that I could find but no joy.  que chingadera.  I have
connected apache to tomcat on a number of occassions without problem.  Its just when I get
to IIS that the problems start arising 

kind regards,

Warren Sweetman
Principal Web Developer
Web Development
ISD
Legal Services Commission
tel. 020 77590122
ext no 2122
tag no 011370

>>> alberto.magalhaes@bnc.pt 01/04/2003 17:32:23 >>>
**********************************************************************
Este email assim como os ficheiros que possa ter em anexo são confidenciais
e para uso exclusivo da pessoa ou organização para o qual foi enviado.
Se recebeu este email por engano por favor notifique Redes@bnc.pt 

Esta nota confirma que esta mensagem foi verificada pelo MIMEsweeper
não tendo sido encontrados virus.

www.mimesweeper.com 
***********************************************************************

Did you add entries to Registry?

-----Original Message-----
From: Warren Sweetman [mailto:warren.sweetman@legalservices.gov.uk] 
Sent: terça-feira, 1 de Abril de 2003 17:36
To: tomcat-user@jakarta.apache.org 
Subject: tomcat IIS configuration please help

can anybody assist in the configuration of the isapi_connector2.dll and =
associated files.  My configuration is as follows

W2k
Tomcat 4.1.18
IIS=20
isapi_redirector2.dll

I cant get request for jsps or servlets to be forwarded by IIS to tomcat =
for some reason.  It seems that the dll is not being loaded.

jk2.properties :

# THIS FILE MAY BE OVERRIDEN AT RUNTIME. MAKE SURE TOMCAT IS STOPED
## WHEN YOU EDIT THE FILE.

## COMMENTS WILL BE _LOST_

## DOCUMENTATION OF THE FORMAT IN JkMain javadoc.

# Set the desired handler list
 handler.list=3Dapr,request,channelJni
#
# Override the default port for the socketChannel
 channelSocket.port=3D8019
# Default:=20
 channelUnix.file=3D${jkHome}/work/jk2.socket
# Just to check if the the config  is working
 shm.file=3D${jkHome}/work/jk2.shm

# In order to enable jni use any channelJni directive
 channelJni.disabled =3D 0
# And one of the following directives:

 apr.jniModeSo=3D/opt/apache2/modules/mod_jk2.so

# If set to inprocess the mod_jk2 will Register natives itself
# This will enable the starting of the Tomcat from mod_jk2
 apr.jniModeSo=3Dinprocess

woker2.properties

# Define the communication channel
[channel.socket:localhost:8009]
info=3DAjp13 forwarding over socket
tomcatId=3Dlocalhost:8009


# define the worker
[ajp13:localhost:8009]
channel=3Dchannel.socket:localhost:8009


# Uri mapping. This says that any incoming connection to any file
# under "/jetty/" should be handled the worker defined above

[uri:/*.jsp]
worker=3Dajp13:localhost:8009

[uri:/servlet/*]
worker=3Dajp13:localhost:8009


I also get the following in stdout.log

Bootstrap: Create Catalina server
Bootstrap: Starting service
ServerLifecycleListener: createMBeans: MBeanException
java.lang.Exception: ManagedBean is not found with Ajp13Connector
	at org.apache.catalina.mbeans.MBeanUtils.createMBean(MBeanUtils.jav=
a:224)
	at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(=
ServerLifecycleListener.java:369)
	at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(=
ServerLifecycleListener.java:777)
	at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(=
ServerLifecycleListener.java:751)
	at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(=
ServerLifecycleListener.java:339)
	at org.apache.catalina.mbeans.ServerLifecycleListener.lifecycleEven=
t(ServerLifecycleListener.java:206)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(Lif=
ecycleSupport.java:166)
	at org.apache.catalina.core.StandardServer.start(StandardServer.jav=
a:2182)
	at org.apache.catalina.startup.CatalinaService.start(CatalinaServic=
e.java:273)
	at java.lang.reflect.Method.invoke(Native Method)
	at org.apache.catalina.startup.BootstrapService.start(BootstrapServ=
ice.java:245)
	at org.apache.catalina.startup.BootstrapService.main(BootstrapServi=
ce.java:307)
Starting service Tomcat-Standalone
Apache Tomcat/4.1.18
Bootstrap: Service started


but everything seems ok in the catalina log

2003-04-01 16:58:04 Ajp13Connector[8009] Opening server socket on all host =
IP addresses
2003-04-01 16:58:04 Ajp13Connector[8009] Starting background thread
2003-04-01 16:58:04 Ajp13Processor[8009][0] Starting background thread
2003-04-01 16:58:04 Ajp13Processor[8009][1] Starting background thread
2003-04-01 16:58:04 Ajp13Processor[8009][2] Starting background thread
2003-04-01 16:58:04 Ajp13Processor[8009][3] Starting background thread
2003-04-01 16:58:04 Ajp13Processor[8009][4] Starting background thread




PLEASE HELP

kind regards,

Warren Sweetman
Principal Web Developer
Web Development
ISD
Legal Services Commission
tel. 020 77590122
ext no 2122
tag no 011370



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org 
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org 



Mime
View raw message