tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From johannes.fi...@fwd.at
Subject Re: Apps Deploying to wrong dir?
Date Tue, 29 Apr 2003 20:17:03 GMT
Hi Mike,

1.) Deploying using the manager app always results in the WAR file showing 
up beneath
${CATALINA_BASE}/work/Standalone/localhost/manager/myapp:war

2.) Parts of the WAR files get extracted to the 
${CATALINA_BASE}/work/Standalone/localhost/myapp
directory, currently it seems 
*) all WEB-INF/lib files
*) all WEB-INF/classes files
*) SESSIONS.ser, which holds the serialized session data after shutdown of 
Tomcat.

3.) I've also messed around with the manager app for awhile and have had 
the following troubles so far:
*) sometimes the InitParameter's of context.xml don't get correctly 
initialized.
This is especially the case if you write a redeploy task with ant, to 
perform undeploy/deploy sequentially. This seems to lead to the error of a 
half-inited Context. Only undeploy, waiting a few seconds and then deploy 
seems to help, but not always.
I've posted this quite a few times at this forum, but it seems I'm alone 
with this bug (occurs in Tomcat 4.1.18 + 4.1.24, Windows 2000 
Professional).

*) recently I've had another strange issue with BouncyCastle.
I get a PKCS12 not inited error, after a redeploy. Only a complete 
stop/start of Tomcat helps.
However, sometimes more than one redeploy is necessary to get this error.

Maybe you will run in these troubles as well and maybe you find a way out.

thx
Johannes




Michael Barrett <mike@daboyz.org> 
29.04.2003 01:29
Please respond to
"Tomcat Users List" <tomcat-user@jakarta.apache.org>


To
tomcat-user@jakarta.apache.org
cc

Subject
Apps Deploying to wrong dir?






    Hi, my company is planning on using tomcat for one of their 
applications, and I've been given the task of installing it and setting up 
the application.

    In doing so I've started to mess around with the manager application 
and ant to do deployments and just generally control the application.

    I did my first run of the deployment today, and I'm running into an 
issue.  Instead of the application being deployed into the webapps dir it 
is being deployed in ${CATALINA_BASE}/work/Standalone/localhost/ .  As 
well, some of the files in the war (a .properties file that should be in 
${CATALINA_BASE}/work/Standalone/localhost/${APP}/WEB-INF) isn't showing 
up for some reason.  It's in the .war that I'm using for the deployment, 
so I'm not sure whats going on.

    Any help you can give me on this is much appreciated.  Thanks.

-- 
 ________________________________________________________________________
                Mike Barrett | "I used to read, now I go to raves."
             mike@daboyz.org | -- Random MUNI Rider, speaking
              www.daboyz.org |    to my friend Allison.
 ------------------------+-----------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message