tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph.Stev...@alcatel.be
Subject building apache module of mod_jk on tru64 : osf v5.1
Date Mon, 14 Apr 2003 12:58:44 GMT
hi ;

  after installation en compilation with -so & ssl support of apache
version 2.0.44  i downloaded the tomcat binary version  4.1.24
  & installed the apache-ant-1.5.2  , libtool 1.4.3 , commons-modeler , and
the jakarta-tomcat-connector-4.1.24-src

  the compilation and build of the tomcat module of the mod_jk connector
went without any problem
  then i went to
  jakarta-tomcat-connector-4.1.24-src/jk  and typed ant native
  and  i get an error during the compilation of the apache module of mod_jk
: it seems jni requires the "-pthread" option
  i tried to follow the build structure in depth but couldn't find the
exact place where to put this option ..
  can anyone point this clearly out to me ;  the full description of the
error is :

 [so] Compiling 1 out of 4
Compiling
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni/jk_jnicb.c
       [so] Compile failed 1
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni/jk_jnicb.c
       [so] Command:libtool --mode=compile cc -c -o
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/build/jk/jni/jni/jk_jnicb.o
 -I/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/common
-I/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni
-I/usr/opt/java141/jre/../include -I${build.compiler.base}/include -g -W
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni/jk_jnicb.c
       [so] Output:
       [so] rm -f
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/build/jk/jni/jni/.libs/jk_jnicb.lo
       [so] cc -c
-I/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/common
-I/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni
-I/usr/opt/java141/jre/../include "-I\${build.compiler.base}/include" -g -W
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/native/jni/jk_jnicb.c
-DPIC -o
/osp/apache24/jakarta-tomcat-connectors-4.1.24-src/jk/build/jk/jni/jni/.libs/jk_jnicb.lo
       [so] StdErr:
       [so] cc: Error: /usr/opt/java141/include/jni.h, line 36: #error
"Modules that interface with Java must be compiled and linked with the
-pthread option" (errormessage)
       [so] #error "Modules that interface with Java must be compiled and
linked with the -pthread option"
       [so] -^


  thx on beforehand
christoph






---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message