tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "neal" <nealcab...@yahoo.com>
Subject RE: Moved classes to Common Dir
Date Sat, 26 Apr 2003 17:15:35 GMT
Actually, yeah ...

the classes I moved to common/classes are my own framework .. the classes
that remain in the webapp/web-inf dir are specific to the webApp.  There is
no dependency that I can see by the common/classes upon the webApp classes,
nor should there be.

The error I recieve occurs when I run my initialization class.  Its trying
to read my config.xml file at it throws this error:

"java.lang.NullPointerException"

Any thoughts?

Thanks.
Neal




-----Original Message-----
From: Jacob Kjome [mailto:hoju@visi.com]
Sent: Friday, April 25, 2003 6:02 AM
To: Tomcat Users List
Subject: Re: Moved classes to Common Dir



Note that your webapp can see the classes in the jars of the shared/lib or
common/lib directories, but not vice-versa, unless you make sure to use the
thread context class loader.  This is something you have to watch out for
when attempting to use parent/child classloader combinations.

Jake

At 10:31 PM 4/24/2003 -0700, you wrote:
>I moved some classes from my webApp's web-inf directory, to the Tomcat
>Common directory so that another webApp could share the same classes.  But,
>now I'm getting errors when I start Tomcat.
>
>Shouldn't it have been this simple?  What did I miss?
>
>Thanks
>Neal
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message