tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Brownlee" <osaru_onl...@hotmail.com>
Subject Re: Error building mod_jk on Solaris 8
Date Tue, 15 Apr 2003 21:26:47 GMT
Does the Makefile in 
/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/apache-1.3 look 
OK?  Line 21 may be bogus so look for qoutes that don't have close quotes, 
etc.  Of course, this may indicate a bigger problem with configure.

On a side note, I'm confused about where to get the source for the tomcat 
connectors.  It looks like you grabbed the file from 
http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.2/src 
but this file has not been updated since 12/17/2002.  I've been trying to 
use the source from 
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.24/src
which contains what I assume is the current version of all the connectors.  
Is there a difference or is the mod_jk in the 4.1.24 tarball the same 
v1.2.2?

>From: Ben Ricker <bricker@wellinx.com>
>Reply-To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
>To: Tomcat Users List <tomcat-user@jakarta.apache.org>
>Subject: Re: Error building mod_jk on Solaris 8
>Date: 15 Apr 2003 15:55:01 -0500
>MIME-Version: 1.0
>Received: from apache.org ([208.185.179.12]) by mc6-f32.law1.hotmail.com 
>with Microsoft SMTPSVC(5.0.2195.5600); Tue, 15 Apr 2003 14:00:21 -0700
>Received: (qmail 62514 invoked by uid 500); 15 Apr 2003 20:59:57 -0000
>Received: (qmail 61255 invoked from network); 15 Apr 2003 20:59:03 -0000
>Received: from unknown (HELO popc2wi1.wellinx.com) (12.25.236.118)  by 
>daedalus.apache.org with SMTP; 15 Apr 2003 20:59:03 -0000
>Received: from dhcp40.wellinx.com (dhcp40.wellinx.com [172.16.31.40])by 
>popc2wi1.wellinx.com (8.12.6/8.12.6) with ESMTP id h3FKx9fV023079for 
><tomcat-user@jakarta.apache.org>; Tue, 15 Apr 2003 15:59:09 -0500
>X-Message-Info: JGTYoYF78jEHjJx36Oi8+Q1OJDRSDidP
>Mailing-List: contact tomcat-user-help@jakarta.apache.org; run by ezmlm
>Precedence: bulk
>List-Unsubscribe: <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>List-Subscribe: <mailto:tomcat-user-subscribe@jakarta.apache.org>
>List-Help: <mailto:tomcat-user-help@jakarta.apache.org>
>List-Post: <mailto:tomcat-user@jakarta.apache.org>
>List-Id: "Tomcat Users List" <tomcat-user.jakarta.apache.org>
>Delivered-To: mailing list tomcat-user@jakarta.apache.org
>In-Reply-To: <1050428612.9608.22.camel@localhost.wellinx.com>
>References: <1050428082.9608.20.camel@localhost.wellinx.com> 
><1050428612.9608.22.camel@localhost.wellinx.com>
>Organization: Wellinx.com
>Message-Id: <1050440100.9625.117.camel@localhost.wellinx.com>
>X-Mailer: Ximian Evolution 1.2.3- X-RAVMilter-Version: 8.4.1(snapshot 
>20020919) (popc2wi1.wellinx.com)
>X-Spam-Rating: daedalus.apache.org 1.6.2 0/1000/N
>Return-Path: 
>tomcat-user-return-60825-osaru_online=hotmail.com@jakarta.apache.org
>X-OriginalArrivalTime: 15 Apr 2003 21:00:21.0960 (UTC) 
>FILETIME=[07549C80:01C30392]
>
>Thanks for all the help. I used John Grivsky's suggestions on which pkgs
>to install and used David Brownlee's suggestion on pathing /usr/ccs/bin
>before /usr/local/bin. I got through the buildconf.sh and the configure.
>
>However, I am failing with the following error, which looks like an
>issue with the the configure's makefile:
>
>gcc -I/usr/local/apache/include -g -O2 -DSOLARIS2=280 -DEAPI -O3 -g -O2 -I 
>/include -I /include/ -c jk_context.c -o jk_context.o >/dev/null 2>&1
>mv -f .libs/jk_context.lo jk_context.lo
>Making all in apache-1.3
>make: Fatal error in reader: Makefile, line 21: Unexpected end of line seen
>Current working directory 
>/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/apache-1.3
>*** Error code 1
>make: Fatal error: Command failed for target `all-recursive'
>
>FYI, I also tried to use the apache source to build it (used
>--with-apache) but got the same error.
>
>Anyone?
>
>Ben Ricker
>
>On Tue, 2003-04-15 at 12:43, Ben Ricker wrote:
> > Sorry! My previous email should have 'Tomcat' replaced by 'mod_jk' in
> > the subject. Consider this the thread.
> >
> > Ben Ricker
> >
> >
> > On Tue, 2003-04-15 at 12:34, Ben Ricker wrote:
> > > I am having trouble with the binaries posted to Tomcat's web site 
>built
> > > for Solaris 8 so I am trying to roll my own.
> > >
> > > I have gcc and make installed:
> > >
> > > pkginfo -il  |grep gcc
> > >    PKGINST:  SMCgcc
> > >       NAME:  gcc
> > >    PKGINST:  SMClibgcc
> > >       NAME:  libgcc
> > >
> > > pkginfo -il  |grep make
> > >       NAME:  automake
> > >    PKGINST:  SMCmake
> > >       NAME:  make
> > >
> > > I run the following taken directly from the following URL:
> > > 
>http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.2/doc/jk/aphowto.html
> > >
> > > ./configure --with-apxs=/usr/local/apache/bin/apxs
> > >
> > > using Apache 1.3.27. This is in the
> > > /home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native 
>directory.
> > > Configure runs fine, at least, there is no glaring errors which cause 
>it
> > > to fail. It creates a number of make files (I can show the complete
> > > output if someone requests it).
> > >
> > > I then run 'make' per the instructions and get the following output:
> > >
> > > make
> > > Making all in common
> > > make[1]: Entering directory
> > > `/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/common'
> > > 
>/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/home/admin/bin:/usr/local/apache/bin/:usr/local/apache:/usr/sbin/:/usr/sbin/app_scripts:/usr/ccs/bin

>--mode=compile gcc -I/usr/local/apache/include -g -O2 -DSOLARIS2=280 -DEAPI 
>-O3 -g -O2  -I /include -I /include/ -c jk_ajp12_worker.c
> > > make[1]:
> > > 
>/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/home/admin/bin:/usr/local/apache/bin/:usr/local/apache:/usr/sbin/:/usr/sbin/app_scripts:/usr/ccs/bin:

>Command not found
> > > make[1]: *** [jk_ajp12_worker.lo] Error 127
> > > make[1]: Leaving directory
> > > `/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/common'
> > > *** Error code 1
> > > make: Fatal error: Command failed for target `all-recursive'
> > >
> > > I am not sure what it is failing on; it looks like gcc is the "command
> > > not found" but configure finds gcc just fine. Anyone have any ideas 
>what
> > > is failing here?
> > >
> > > Thanks,
> > >
> > > Ben Ricker
>--
>Ben Ricker <bricker@wellinx.com>
>Wellinx.com
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>


_________________________________________________________________
STOP MORE SPAM with the new MSN 8 and get 2 months FREE*  
http://join.msn.com/?page=features/junkmail


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message