tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weaver, Gregory" <gwea...@med.wayne.edu>
Subject tomcat 4.1.24 SSL configuration
Date Mon, 14 Apr 2003 14:55:35 GMT
Hell I am having issues with the SSL configuration for tomcat 4.1.24. 

here is my connector config from my server.xml

    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" acceptCount="40" bufferSize="2048"
               compression="off" connectionLinger="-1" connectionTimeout="20000" debug="0"
               disableUploadTimeout="true" enableLookups="false" maxKeepAliveRequests="100"
               maxProcessors="75" minProcessors="5" port="8443" proxyPort="0"
               scheme="https" secure="true" tcpNoDelay="true" useURIValidationHack="false">
      <Factory className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory" clientAuth="false"
protocol="TLS"/>
    </Connector>

Now it starts up just fine, but the problem is that when I go through my browser(explorer,opera)
to https://mymachine:8443/ I get just an empty file from the server.

The browser/server seem to not be handshaking the certificate properly.

I have generated the keystore like this:
keytool -genkey -alias tomcat -keyalg RSA

This works for the tomcat version 4.0.6 that we are currently running.

Am I setting this up properly? Or am I missing something important?

I have tried to read through the documentation and I could not search the maling list on the
apache we site I get an error.

Thanks in advance for any help.

Gregory J. Weaver
Database Analyst II - Wayne State University
30 E. Canfield Room 230
Detroit, MI 48201
(313)-580-1570


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message