tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lopez David E-r9374c <r93...@motorola.com>
Subject Mating Apache 1.3.26 with Tomcat 4.1.18
Date Tue, 08 Apr 2003 19:10:38 GMT
Ladies and Gents

Hardware: Solaris 5.8
SW: Tomcat 4.1.18, Apache 1.3.26

Can't load apache module mod_jk2-2.0.43.so 
      Error: symbol apr_pool_cleanup_null not referenced

So I tried module mod_jk-1.3-eapi.so
      Error: symbol ap_ctx_get not referenced

Both modules were loaded from binaries in location
 /builds/jakarta-tomcat-connectors/jk/release/v1.2.1/bin/solaris8

I tried the auto-generating configuration settings by
using the following code in the conf/server.xml file:

<Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
      modJk="/opt/apache/default/modules/mod_jk-1.3-eapi.so"
      workersConfig="/opt/jakarta/default/conf/jk/workers.properties"
      jkLog="/opt/jakarta/default/logs/mod_jk.log"
      jkDebug="info"
/>

This creates the file conf/auto/mod_jk.conf 

########## Auto generated on Tue Apr 08 11:16:41 MST 2003##########

<IfModule !mod_jk.c>
  LoadModule jk_module /opt/apache/default/modules/mod_jk-1.3-eapi.so
</IfModule>

I load this file from apache configuration conf/httpd.conf:
  Include /opt/jakarta/default/conf/auto/mod_jk.conf

I start tomcat first, followed by apache. 

Since this doesn't work, what is my problem? Obiously this setup
is missing a library or something else. Any ideas?

Thanks in advance

David

PS I'm a servlet, jsp developer, but now I'm trying to mate
Apache to tomcat.

---
David E Lopez
Org:   SPS->WBSG->WITC->SOC->CSAM
Phone: 480-413-6251
email: R9374C@motorola.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message