tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mpet...@trask.cz
Subject RE: JK2 + IIS5 not running
Date Tue, 08 Apr 2003 13:56:03 GMT
OK, anyway i have no more power to try it today! :-) 

Milan

-----Original Message-----
From: Konrad Rusz [mailto:konrad@ogumienie.pl] 
Sent: Tuesday, April 08, 2003 3:54 PM
To: Tomcat Users List
Subject: Re: JK2 + IIS5 not running


Hi Milan,

Take it easy. Unfortunatelly I have to go home, therefore I shall be
able to answer for your next e-mails only tomorrow.

Good luck,
Konrad


----- Original Message -----
From: "Milan Petran" <mpetran@trask.cz>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, April 08, 2003 3:34 PM
Subject: RE: JK2 + IIS5 not running


Hello Konrad,

I am posting all the setting I have done here, so please have a minute
to go through it, it is really long so don't b scared :-)

system configuration:
===============
W2000 SP-3 Professional (workstation), Tomcat 4.1.24, JDK 1.3.1, IIS 5,
JK2 v2.0.2 (isapi_redirector2.dll)

By quick change to isapi_redirect.dll (standard JK) everything works
fine..

I have no %CATALINA_HOME%\webapps\ROOT\WEB-INF, what is that for?

IIS 5.0 (W2000 Workstation) settings: ===========================
Default website - isapi filter called "Jakarta" with 2.0.2 version
isapi_redirector2.dll under it two virtual directories: 1/ jakarta
(points to directory where isapi_redirector2.dll
resides) - scripts and executables rights
2/ edoceo (our application)

ISAPI filter is running (dll loaded) - so I expect that registry setting
are also OK

Registry settings (exported key from regedit)
================================ [HKEY_LOCAL_MACHINE\SOFTWARE\Apache
Software Foundation\Jakarta Isapi Redirector\2.0]
"serverRoot"="c:\\Program Files\\Apache Group\\Tomcat 4.1"
"extensionUri"="/jakarta/isapi_redirector2.dll"
"workersFile"="c:\\Program Files\\Apache Group\\Tomcat
4.1\\conf\\workers2.properties" "authComplete"="0" "threadPool"="20"
"logLevel"="DEBUG"

Environment variables settings
======================
I have not set any environment except JAVA_HOME (points to c:\jdk1.3.1)
because I need to use more than one Tomcat with the same application
(and the same contextroot)

Workers2.properties settings
=====================
file resides in "c:\Program Files\Apache Group\Tomcat 4.1\conf\"

Full file listing:

#workers2.properties file beginning
[logger]
level=DEBUG

$serverRoot="c:/Program Files/Apache Group/Tomcat 4.1"

[config:]
file=${serverRoot}/conf/workers2.properties
debug=1
debugEnv=0

[uriMap:]
info=Maps the requests. Options: debug
debug=1

# Uri mapping
[uri:/*.jsp]
[uri:/edoceo/screen/*]
[uri:/edoceo/support/*]
[uri:/edoceo/sap/*]
[uri:/edoceo/security/*]
[uri:/edoceo/courseresult/*]

# Alternate file logger
[logger.file:0]
level=DEBUG
file="c:/Program Files/Apache Group/Tomcat 4.1/logs/jk2.log"

#[shm:]
#info=Scoreboard. Required for reconfiguration and status with
multiprocess servers #file=${serverRoot}/logs/jk2.shm #size=1000000
#debug=10 #disabled=0

[workerEnv:]
info=Global server options
timing=1
debug=1
# Default Native Logger (apache2 or win32 )
# can be overriden to a file logger, useful
# when tracing win32 related issues
logger=logger.file:0

[lb:lb]
info=Default load balancer.
debug=10

#[lb:lb_1]
#info=A second load balancer.
#debug=10

[channel.socket:mpetran.trask.cz:8009]
info=Ajp13 forwarding over socket
debug=10
tomcatId=mpetran.trask.cz:8009

#[channel.socket:mpetran.trask.cz:8019]
#info=A second tomcat instance.
#debug=10
#tomcatId=mpetran.trask.cz:8019
#lb_factor=1
#group=lb
#group=lb_1
#disabled=0

#[channel.un:/opt/33/work/jk2.socket]
#info=A second channel connecting to mpetran.trask.cz:8019 via unix
socket #tomcatId=mpetran.trask.cz:8019 #lb_factor=1 #debug=0

#[channel.jni:jni]
#info=The jni channel, used if tomcat is started inprocess

[status:]
info=Status worker, displays runtime informations

[vm:]
info=Parameters used to load a JVM in the server process
#JVM=C:\jdk\jre\bin\hotspot\jvm.dll
classpath=${TOMCAT_HOME}/bin/tomcat-jni.jar
classpath=${TOMCAT_HOME}/server/lib/commons-logging.jar
OPT=-Dtomcat.home=${TOMCAT_HOME} OPT=-Dcatalina.home=${TOMCAT_HOME}
OPT=-Xmx128M
#OPT=-Djava.compiler=NONE
disabled=1

#[worker.jni:onStartup]
#info=Command to be executed by the VM on startup. This one will start
tomcat. #class=org/apache/jk/apr/TomcatStarter
#ARG=start
# For Tomcat 5 use the 'stard' for startup argument
# ARG=stard
#disabled=1
#stdout=${serverRoot}/logs/stdout.log
#stderr=${serverRoot}/logs/stderr.log

#[worker.jni:onShutdown]
#info=Command to be executed by the VM on shutdown. This one will stop
tomcat. #class=org/apache/jk/apr/TomcatStarter
#ARG=stop
#disabled=1

#workers2.properties file end


Server.xml settings
=====================
file resides in "c:\Program Files\Apache Group\Tomcat 4.1\conf\"

Full file listing:

#server.xml file beginning
<Server port="8005" shutdown="SHUTDOWN" debug="0">

<!-- Define the Tomcat Stand-Alone Service -->
<Service name="Tomcat-Standalone">

<!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009
-->
<Connector

className="org.apache.coyote.tomcat4.CoyoteConnector"
port="8009"
minProcessors="5"
maxProcessors="75"
enableLookups="true"
redirectPort="8443"
acceptCount="10"
debug="0"
connectionTimeout="20000"
useURIValidationHack="false"

protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/>

<!-- Define an AJP 1.3 Connector on port 8009 -->
<!-- <Connector

className="org.apache.ajp.tomcat4.Ajp13Connector"
port="8009"
minProcessors="5"
maxProcessors="75"
acceptCount="10"
debug="0"/>  -->

<!-- Define the top level container in our container
hierarchy -->
<Engine name="Standalone" defaultHost="localhost"
debug="0">

<!-- Global logger unless overridden at
lower levels -->
<Logger

className="org.apache.catalina.logger.FileLogger"
prefix="catalina_log."
suffix=".log"
timestamp="true"/>

<!-- Define the default virtual host -->
<Host
name="localhost"
debug="0"
appBase="webapps"
unpackWARs="false"
autoDeploy="true">

<Logger

className="org.apache.catalina.logger.FileLogger"
directory="logs"


prefix="localhost"
suffix=".log"

timestamp="true"/>

</Host>

</Engine>

</Service>

</Server>
#server.xml file end








-----Original Message-----
From: Konrad Rusz [mailto:konrad@ogumienie.pl]
Sent: Tuesday, April 08, 2003 3:07 PM
To: Tomcat Users List
Subject: Re: JK2 + IIS5 not running


Hello Milan,

Tell me, please, have you added a virtual site naming 'jakarta' to your
web site which is using to redirect jsp files or servlets (in IIS, of
course) to Tomcat? Have you typed proper entries in
'workers2.properties' file, it means, entries which representing when
redirection from IIS to Tomcat is executing, e.g. [uri:/sights/*]
info=This example show us that all files under /sights/ are redirected
to Tomcat.

Check your 'web.xml' file under %CATALINA_HOME%\webapps\ROOT\WEB-INF. It
should contains such entries as these (for above example): <web-app>
<!--
 It is needed in order to your application can work with context
/sights/*  -->
    <servlet-mapping>
        <servlet-name>invoker</servlet-name>
        <url-pattern>/sights/*</url-pattern>
    </servlet-mapping>
<\web-app>

Check entries in registry once again:
[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector\2.0] "serverRoot"="Your_CATALINA_HOME"
"extensionUri"="/jakarta/isapi_redirector2.dll"
"workersFile"="Your_CATALINA_HOME\\conf\\workers2.properties"
"authComplete"="0"
"threadPool"="20"

Of course, localisation of your 'workers2.properties' file may be
different. Try to do it.

Regards,
Konrad Rusz


----- Original Message -----
From: "Milan Petran" <mpetran@trask.cz>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, April 08, 2003 1:29 PM
Subject: JK2 + IIS5 not running


Hi,

I still cannot run Tomcat 4.1.24 with IIS5 and JK2 (isapi_redirect2.dll)
on W2000.

I configured registry, workers2.properties and server.xml in cooperation
with apache.org site and this mailing list but even if my application
starts, the requests returns "The page cannot be displayed" page. No
errors in Event log.

It seem that the redirector does not redirect the servlet requests
(isapi arrow is up - green)...

Can someone give me clue?

Thanx

Milan Petran


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message