tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject endorsed classes
Date Tue, 08 Apr 2003 20:20:23 GMT
I read a post stating the endorsed directories have a higher class loading 
priority than any of the Tomcat class loaders in Tomcat 4.1.

I found this in the link from entitled "Another 
answer to a classloader issues."

Does this mean you can never override the Xerces version (xercesImpl.jar) 
or parser APIs (xmlParserAPIs.jar) since these are in 

If so, this is the source of my problem trying to use Xerces 1.4.4 and JAXP 
I get a VerifyError each time I try to use the 
setErrorHandler(org.xml.sax.ErrorHandler) method in my application.
This worked fine with Tomcat 3.2.4 in-process but fails every time in 
Tomcat 4.1.24 out-of-process.

Please help.  I have been stumped by this VerifyError for over a week now.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message