tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Vidaver <gvida...@bbn.com>
Subject Help with deploying a web app
Date Tue, 15 Apr 2003 02:06:19 GMT
Hi,
         I've extended the tomcat sample build.xml, but I'm having a 
problem where I can use an ant target to deploy a web app:

   <target name="deploy" description="Deploy the application to the servlet 
container">
     <install url="${manager.url}"
         username="${manager.username}"
         password="${manager.password}"
             path="${app.path}"
              war="file://${basedir}/dist/MyApp.war"/>
   </target>

         and this works fine, BUT if I copy the war into the webapps 
directory, I get a 404.  Is there any fundamental step I'm missing here?

         I can see tomcat expanding the war and all the pieces seem to be 
there.

         I turned the debug level to 99 on the obviously relevant 
server.xml elements, but nothing in the logs say "I'm throwing an exception 
so I won't work, etc."

         Any help anyone can provide would be most appreciated.

         Thanks,

         Gordon


Gordon Vidaver                  BBN Technologies
gvidaver@bbn.com                Office 6/323
617 873-3558                    10 Moulton St.
617 873-2616 (fax)              Cambridge, MA 02138
866-322-9311 (toll free)


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message