tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: Tomcat 4.1, Standalone, Port 80, Coyote
Date Mon, 14 Apr 2003 16:39:23 GMT
You need to be root to bind to port 80. Which will then spark the root 
converations which are discuessed here ...

http://tomcatfaq.sourceforge.net/security.html

-Tim

Dan Tarkenton wrote:
> Hello all. I have configured Tomcat 4.1 to act as a standalone and to handle requests
submitted through port 80 on win2k pro platform.  This was obviously quite simple to do by
editing the server.xml file.  I simply changed the standalone Service's Coyote Connector port
from 8080 to 80.  Pretty simple. <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
port="80" minProcessors="5" maxProcessors="75" enableLookups="true" redirectPort="8443" acceptCount="100"
debug="0" connectionTimeout="20000" useURIValidationHack="false" disableUploadTimeout="true"
/>  However, I tried to recreate this setup on Redhat 8.0.  When I try to access http://localhost/foo,
I receive a "connection refused message".  I did not get this before on the linux machine
when I had the port set to 8080 (and I accessed http://localhost:8080/foo).  I noticed that
once I had the port set to 80, and tried to start tomcat, that there were error messages in
the catalina.out log file.  Basically the 
error stated "SEVERE: Error Initializing endpoint.  java.net.BindException:  Permission Denied:80"
 This would explain why I am getting "connection refused" messages in my browser. What do
I have to do to get tomcat to bind to port 80?  There must be some conflict.  I have apache
installed, but it is not running.  Perhaps apache has some lock or bind to port 80 somewhere?
I'm lost here in the linux world.  Any help would be greatly appreciated.   Thanks.
> 
> 
> ---------------------------------
> Do you Yahoo!?
> Yahoo! Tax Center - File online, calculators, forms, and more


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message