tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: endorsed classes
Date Wed, 09 Apr 2003 11:45:35 GMT
You have code compiled against Xerces 1.4.4 and wish to run in tomcat4 which 
has xerces 2.3?

I don't have an answer but am curious in this thread.

-Tim

bahbahbooie@go.com wrote:
> I read a post stating the endorsed directories have a higher class 
> loading priority than any of the Tomcat class loaders in Tomcat 4.1.
> 
> I found this in the link from 
> http://tomcatfaq.sourceforge.net/classnotfound.html entitled "Another 
> answer to a classloader issues."
> 
> Does this mean you can never override the Xerces version 
> (xercesImpl.jar) or parser APIs (xmlParserAPIs.jar) since these are in 
> $CATALINA_HOME/common/endorsed?
> 
> If so, this is the source of my problem trying to use Xerces 1.4.4 and 
> JAXP 1.1.
> I get a VerifyError each time I try to use the 
> setErrorHandler(org.xml.sax.ErrorHandler) method in my application.
> This worked fine with Tomcat 3.2.4 in-process but fails every time in 
> Tomcat 4.1.24 out-of-process.
> 
> Please help.  I have been stumped by this VerifyError for over a week now.
> 
> Thanks.
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message