tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mart Käsper <m...@netsoftlund.se>
Subject Setting system properties for Tomcat as NT service ?
Date Tue, 08 Apr 2003 10:03:45 GMT
Hi,

I'm running Tomcat 4.1.24 (invoked from IIS) on a Win2K box as a NT 
service. It starts OK and seems to execute my classes fine, but my 
classes cannot find the system properties I've tried to set.

What I did was (roughly):
* installed Tomcat, instructing it to register as a service
* set CATALINA_OPTS as an environment variable containing my -D... settings
* restarted Tomcat and invoking the servlet

but my environment variables were not found (System.getProperty() 
returned null).

I even tried editing catalina.bat just to get some clues, but it just 
left me more confused - nothing happened.

Is it so that I should have set CATALINA_OPTS before installing Tomcat, 
or what ? If it is - how do I re-register the Tomcat service ?

Thanks in advance,

======================================================================
    Mart Käsper                 E-mail            : mart@netsoftlund.se
    Netsoft Lund AB
    Bredgatan 17                Tel (in place)    : +46 46  19 04 95
    SE-222 21 Lund, Sweden      Tel (on the road) : +46 70 319 04 95
======================================================================

    This e-mail is a work of fiction. Names, characters, places and
    incidents are products of the author's imagination or are used
    fictitiously. Any resemblance to actual events or locales or
    persons, living or dead, is entirely coincidental.

    Also, no animals were hurt during the creation and transfer of
    this e-mail.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message