tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Ricker <bric...@wellinx.com>
Subject Re: Error building mod_jk on Solaris 8
Date Tue, 15 Apr 2003 17:43:32 GMT
Sorry! My previous email should have 'Tomcat' replaced by 'mod_jk' in
the subject. Consider this the thread.

Ben Ricker


On Tue, 2003-04-15 at 12:34, Ben Ricker wrote:
> I am having trouble with the binaries posted to Tomcat's web site built
> for Solaris 8 so I am trying to roll my own. 
> 
> I have gcc and make installed:
> 
> pkginfo -il  |grep gcc
>    PKGINST:  SMCgcc
>       NAME:  gcc
>    PKGINST:  SMClibgcc
>       NAME:  libgcc
> 
> pkginfo -il  |grep make
>       NAME:  automake
>    PKGINST:  SMCmake
>       NAME:  make
> 
> I run the following taken directly from the following URL:
> http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.2/doc/jk/aphowto.html
> 
> ./configure --with-apxs=/usr/local/apache/bin/apxs
> 
> using Apache 1.3.27. This is in the
> /home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native directory.
> Configure runs fine, at least, there is no glaring errors which cause it
> to fail. It creates a number of make files (I can show the complete
> output if someone requests it). 
> 
> I then run 'make' per the instructions and get the following output:
> 
> make
> Making all in common
> make[1]: Entering directory
> `/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/common'
> /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/home/admin/bin:/usr/local/apache/bin/:usr/local/apache:/usr/sbin/:/usr/sbin/app_scripts:/usr/ccs/bin
--mode=compile gcc -I/usr/local/apache/include -g -O2 -DSOLARIS2=280 -DEAPI -O3 -g -O2  -I
/include -I /include/ -c jk_ajp12_worker.c
> make[1]:
> /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/home/admin/bin:/usr/local/apache/bin/:usr/local/apache:/usr/sbin/:/usr/sbin/app_scripts:/usr/ccs/bin:
Command not found
> make[1]: *** [jk_ajp12_worker.lo] Error 127
> make[1]: Leaving directory
> `/home/admin/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native/common'
> *** Error code 1
> make: Fatal error: Command failed for target `all-recursive'
> 
> I am not sure what it is failing on; it looks like gcc is the "command
> not found" but configure finds gcc just fine. Anyone have any ideas what
> is failing here?
> 
> Thanks,
> 
> Ben Ricker
-- 
Ben Ricker <bricker@wellinx.com>
Wellinx.com


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message