tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Bibby" <ch...@chrisbibby.org.uk>
Subject Re: Tomcat 4.1.24 - Win98 - Blank Screen
Date Tue, 15 Apr 2003 14:50:18 GMT
> Have you changed your classpath?

no, the following are all correct and right as far as i know:
Using CATALINA_BASE:   c:\tomcat
Using CATALINA_HOME:   c:\tomcat
Using CATALINA_TMPDIR: c:\tomcat\temp
Using JAVA_HOME:       C:\J2SDK_Forte\jdk1.4.0

> Where is servlet.jar located?
C:\tomcat\common\lib


I have servlet.jar in C:\J2SDK_Forte\jdk1.4.0\jre\lib\ext and its a
different size:
-C:\J2SDK_Forte\jdk1.4.0\jre\lib\ext  - - servlet.jar -- 21KB
-C:\tomcat\common\lib - - servlet.jar -- 79KB

Should these 2 be the same?
Also, do I need to set the CATALINA paths through autoexec.bat or can I just
do it at run-time?


Thanks, Chris


----- Original Message -----
From: "Bodycombe, Andrew" <andrew.bodycombe@siemens.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, April 15, 2003 3:35 PM
Subject: RE: Tomcat 4.1.24 - Win98 - Blank Screen


> Sounds like you could be using an old version of servlet.jar
>
> Have you changed your classpath?
> Where is servlet.jar located?
>
> It should be in %CATALINA_HOME%\common\lib
>
> Andy
>
> -----Original Message-----
> From: Christopher Bibby [mailto:chris@chrisbibby.org.uk]
> Sent: 15 April 2003 13:56
> To: Tomcat Users List
> Subject: Tomcat 4.1.24 - Win98 - Blank Screen
>
>
> hi, this is the first mailling list ive been on so forgive my stupidness!
>
> I'm trying to run Tomcat 4.1.24 on a Windows 98 box but have a problem.
> Everything installs fine with the binary file and the server seems to be
> awaiting a connection but when I try to go to http://localhost:8080/ I get
> this back as the HTML code:
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
> <META http-equiv=Content-Type content="text/html;
> charset=windows-1252"></HEAD> <BODY><PRE></PRE></BODY></HTML>
>
> The server is there and listening, but it doesn't seem to want to get
> documents and give them to the client??
>
> The error log is:
> 2003-04-15 12:32:25 CoyoteAdapter An exception or error occurred in the
> container during the request processing
> java.lang.NoSuchMethodError:
> javax.servlet.http.HttpServletRequest.getContextPath()Ljava/lang/String;
>  at
>
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
> va:160)
>  at
>
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
> eNext(StandardPipeline.java:643)
>  at
>
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
>  at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
>  at
> org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2415)
>  at
>
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180
> )
>  at
>
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
> eNext(StandardPipeline.java:643)
>  at
>
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.
> java:170)
>  at
>
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
> eNext(StandardPipeline.java:641)
>  at
>
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:172
> )
>  at
>
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
> eNext(StandardPipeline.java:641)
>  at
>
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
>  at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
>  at
>
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
> :174)
>  at
>
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
> eNext(StandardPipeline.java:643)
>  at
>
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
>  at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
>  at
org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java:223)
>  at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:432)
>  at
>
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConne
> ction(Http11Protocol.java:386)
>  at
> org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:534)
>  at
>
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
> a:530)
>  at java.lang.Thread.run(Thread.java:536)
>
> Please help as this is taking too long(!)
>
> Thank you
> Chris
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message