tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "RK Paleru" <rpal...@uncc.edu>
Subject SSL - IP Based Virtual Host Apache!
Date Thu, 10 Apr 2003 16:34:39 GMT
Hi, 

I am posting this messag after trying for over 15 hours myself to solve - I guess - a simple
problem. 

I am using Apache 2.0.45 on Windows 2000. I have connected to Tomcat 4.1.24 using the mod_ssl
(JK Connector). Everything worked fine with static and dynamic content getting handled properly.

I run a single website on the Windows 2000 machine "c:\mywebsite" - static content. My dynamic
content is stored in {tomcat_home}\webapps\mywebapp......and gets served.

Now I have just integrated mod_ssl and openssl 0.9.7a on the Apache Web Server. I have installed
SSL certificates, keys etc. 

1. The first question is primary...and pertains to just static content (from "c:\mywebsite")
getting served by Apache.

When I call http://localhost/ then it loads the index.html page from "C:\mywebsite".  When
I call https://localhost/ the same page gets loaded with the security certificate (with a
lock at the bottom) and I am sure it is in the encrypted mode.

When I access the same server from the internet http://mydomain.com/ then too it works fine......with
the index.html page getting served from "C:\mywebsite".  

Now when I try to load https://mydomain.com/ via the internet then I get a "page not found
error". This happens only in the https mode from the internet. I tried using Name Based Virtual
hosts and it failed....realised I cant use Name Based Virtual hosts when using SSL.

I tried Virtual Hosts *:80 and *:443 for the two treating the requests separately...still
failure.

I removed all virtual hosts except * and even then the same continues......

2. I am having problems connecting to my 

{tomcat_home}\webapps\mywebapp even from https://localhost/mywebapp. It works fine with HTTP.
 But when I try the same with https the request goes as http://localhost:443/mywebapp and
I get a bad request error page ....saying I am trying to speak http protocol with https or
443 port.....


Please help (especially the first one and I can move ahead with the second).

regards

RK


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message