tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: content-length not logged by AccessLogInterceptor?
Date Sun, 13 Apr 2003 04:16:03 GMT
Looking at the code, I can't see why this should occur.  I don't use
AccessLogInterceptor much myself, but I'm very interested in the problem.
If you could post a simple web-app that demonstraist this problem to
http://nagoya.apache.org/bugzilla, I'd like to look into it.

----- Original Message -----
From: "Michael A. Dickerson" <mikey@cs.pomona.edu>
Newsgroups: gmane.comp.jakarta.tomcat.user
Sent: Saturday, April 12, 2003 1:51 PM
Subject: content-length not logged by AccessLogInterceptor?


> I'm using Tomcat 3.3.1 as a standalone server and trying to use the
> AccessLogInterceptor to generate "combined" access logs in the style of
> Apache.  However, I'm finding that Tomcat always writes "?" where the
> content-length should be.
>
> This used to work when I was running Tomcat 3.2.3, which I had hacked
> AccessLogInterceptor onto, once I made sure all of my servlets were using
> setContentLength().  Now, AccessLogInterceptor seems to be included with
> Tomcat but does not work.
>
> I have searched the list archives, Bugzilla, and Google to no avail.  Does
> anyone know what the problem could be?
>
> Thanks,
> M. Dickerson
>
> .... ....... .... ....... .... ....... .... ....... .... ....... ....
> : Michael A. Dickerson                   Andrew 252a / 909.607.8653 :
> : Unix Systems Administrator, Pomona College, Claremont, California :
> .... ....... .... ....... .... ....... .... ....... .... ....... ....


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message