tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Chamberlin" <ma...@easystreet.com>
Subject Tomcat RMI and Eclipse
Date Thu, 03 Apr 2003 01:41:49 GMT
Hi, I have a puzzler and hope someone on this group might be able to give me a few pointers
as to where to look for a solution....  I am running the Tomcat 4.1.18 server on a Win2000
machine and am developing a servlet which will act as an RMI client and makes remote calls
to another machine. For the most part this RMI link is working, especially for remote method
calls which pass and/or return simple Java objects such as ints or strings. However, I have
one method which I call that passes and returns a more complex object (which has been declared
as serializable) and it is with this method that I am having a problem/puzzler. 

For development purposes, I am using the Eclipse IDE with the Tomcat plugin. When I run the
Tomcat server from within the Eclipse IDE, and test out my servlet, everything works fine
including all RMI calls, and in particular the call to this remote method to which I am passing
and returning a more complex Java object!

However, when I run the Tomcat server standalone, when the servlet makes this particular RMI
call, to this method passing and returning the complex Java object, I get the following exception:

java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:


java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is: 

java.net.MalformedURLException: no protocol: Group/Tomcat



Note, the servlet has made a number of RMI calls to the remote object, successfully, prior
to making this particular call. Why this particular call works when Tomcat is running within
the Eclipse IDE and fails when Tomcat is running standalone has got me puzzled! It does not
matter whether I turn debugging on or off for the Tomcat server either. I thought maybe there
 could be some kind of race condition but these calls all occur within the main servlet thread,
so I don't understand how that could be the case. Nor can I come up with anything that might
be timing related.... I have also checked all supporting Jar files and made sure they were
the same...  Any ideas on what else might be different between the Eclipse IDE and the Tomcat
standalone environment?

Any thoughts appreciated....   Marc....



---------------------------------------------------------------------
Do you think the software industry will ever make software
that is as easy and reliable for a user to use 
as the automobile industry makes a car easy and reliable
 for a user to drive?
------------------------------------------------------------------------
A man said unto the universe -  "Sir, I exist!"
"However," replied the universe  "I do not see where that creates in me a sense of an obligation."
          - Stephen Crane
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message