tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ossipetz" <>
Subject tomcat 4.1.18 on linux not loading mysql-driver for a connection-pool?
Date Fri, 07 Mar 2003 17:21:20 GMT

i am just the next beginner so be patient :-)

i started with a small jsp/servlet application that connects to a mysql
database. the connection pool is configured in a context.xml.
running the app under windwos (xp) with tomcat 4.1.18 the thing works fine!

copying/installing the war file to tomcat 4.1.18 on a linux machine it seems
as the mysql driver is not loaded. (exceptions all over)

using the windows version and connectiong to the linux-database works! so
its not a mysql problem.

in the /admin servlet the connection pool is present in the application
context. only the class-name (mysql driver) is surronded in a yellow box.
that means its a problem i guess?

so after reading the
to.html and other sites everything is supposed to work. but well mr linux
doesnt want to agree!

i attached context.xml and web.xml. in web.xml i had to comment the part
        <description>MySQL Database for POST Parameters</description>

for some org.xml.sax.SAXParseException:

/// ContextListener.init(): here we go! :-)
07.03.2003 18:13:42 org.apache.commons.digester.Digester error
SCHWERWIEGEND: Parse Error at line 27 column 11: The content of element type
"web-app" must match

in ch.fhso.formgenerator.httpserver.ContextListener the database is
initialized and closed. but as "resource-ref*" is a valid tag i dont get
why. the lines come from the mentioned howto.

i am using a ant-built script to install the .war file into tomcat.

the version of JConnector is 3.06 but the version 2.x didnt show any

so if someone could come-up with a miracle :)  i just dont see why the
application runs under windows and not under linux (same .war file, same

thanks a lot!


View raw message