tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Johnstone" <Richard.Johnst...@appleyard-contracts.co.uk>
Subject Tomcat and Apache
Date Thu, 06 Feb 2003 11:02:01 GMT
I apologise for sending this as I know there are about 50 posts daily on
this subject but I can't get the 2 of these to link.
I have checked the archives and help docs and everything seems in place
but when I call my servlet without the 8080 port I get nothing. Looking
at the apache logs it says 

/opt/webFrontEnd/examples/servlet/avc.web.Clients.ClientsHomePage

The /opt/webfrontend is my document root for apache

There is no lines in the tomcat logs so apache isn't even posting to
tomcat

I must have missed something simple but I can't see what it is.
Any Help Please

Here is what I have set up in the conf files

SERVER.XML

<Server port="8005" shutdown="SHUTDOWN" debug="0">
<Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
          modJk="/opt/apache/libexec/mod_jk.so"
          jkLog="/opt/apache/logs/mod_jk.log" jkDebug="info"
 />

      <Host name="localhost" debug="0" appBase="webapps"
unpackWARs="true">
      <Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
append="true" />


HTTPD.CONF

Include /opt/tomcat-4.0.6/conf/auto/mod_jk.conf
LoadModule jk_module /opt/apache/libexec/mod_jk.so
AddModule mod_jk.c

JkWorkersFile /opt/tomcat-4.0.6/conf/jk/workers.properties
JkLogFile /opt/apache/logs/mod_jk.log
JkLogLevel info

JkMount /* ajp13
JkMount /examples/* ajp13
JkMount /avcweb/* ajp13

WORKERS.PROPERTIES

workers.tomcat_home=/opt/tomcat-4.0.6
workers.java_home=/opt/jdk1.4.1
ps=/
worker.list=ajp13

worker.ajp13.port=8009
worker.ajp13.host=localhost 
worker.ajp13.type=ajp13

Mime
View raw message