tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Köhler <skoeh...@upb.de>
Subject Re: Problem with Tomcat 4.1.12, coyote connector connectionTimeout
Date Thu, 27 Feb 2003 03:26:53 GMT
you should run apache and use mod_jk. than you can use the webserver's 
support for SSL.

for a heavy loaded site, it's always a good idea, to use apache+mod_jk 
(or some other webserver of course)

i know, that this is only a work-around, but the only sollution i see 
for you at the moment.
i don't believe, that it is a tomcat-bug, because than this should 
happen from the very first start. it must be some kind of weired 
socket-problem perhaps.

Charles Blaxland wrote:
> We have configured Tomcat with the Coyote HTTP/1.1 connector.  It runs fine
> for several days (or even a week), but then all HTTP/1.1 redirects begin
> taking a long time to return - in fact, they take exactly 60 seconds, which
> leads me to believe that it has something to do with the connectionTimeout.
> HTTP/1.0 requests are fine, however.
>  
> Does anyone know what is causing this problem?  Has it been previously
> identified/fixed?  I realise that there have been many fixes in the coyote
> connector in 4.1.18 - unfortunately we can't run 4.1.18 because of the
> problems it has with SSL.  Is there something we can do in 4.1.12 to work
> around this?
>  
> Thanks,
> Charles
>  
>  
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message