tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From liug <l...@mama.indstate.edu>
Subject Re: Help: JNI, mod_jk2 , Apache 2 not working
Date Tue, 11 Feb 2003 18:30:28 GMT
Another happy Microsoft Windows user :)
I tried exactly same config as you did (see my other post) but
it just doesn't want to work on Linux :(

Frank

Rahul Bhargava <coderobo@hotmail.com> wrote:
> Found my problem after building a debug build of mod_jk2 and going thru the
> debugger. It
> was failing to create a shm slot b'cos I didn't have a shm config block!!
> Even though I was not
> running a multi-proc server, just a single proc yet ...#4%^&
> documentation...

> [shm:]
> info=Scoreboard. Required for reconfiguration and status with multiprocess
> servers
> file=${serverRoot}/logs/jk2.shm
> size=1000000
> debug=99
> disabled=0

> _________________________________
> Rahul Bhargava
> ----- Original Message -----
> From: "Robo code" <coderobo@hotmail.com>
> To: <tomcat-user@jakarta.apache.org>
> Cc: <jcubic.tech@gte.net>
> Sent: Saturday, February 08, 2003 10:45 PM
> Subject: RE: Help: JNI, mod_jk2 , Apache 2 not working


> |
> | Hi Jimmy,
> |
> | I have solved some of the problems you are facing. I can get Apache
> | to startTomcat via JNI cleanly. The TomcatStarter problem was solved
> | by putting $TOMCAT/bin/tomcat-jni.jar on the path. I have couple
> | of startup servlets which were correctly loaded. I use Cactus so had
> | to put the log4j*.jar on $TOMCAT/server/lib, once I did that all
> | my startup servlets came up fine.
> |
> | But when I hit Apache with a request meant for a Tomcat hosted
> JSP/Servlet,
> | I get the error below. I tried Apache 2.0.43 since the
> | pre-built mod_jk2.dll on Tomcat site was compiled with 2.0.43 and I
> | get the same error. Attached are the jk2 and worker2 files.
> |
> | Note standalone Tomcat works fine with the web.xml etc. So the culprit
> | must be worker2 or jk2 properties file. Can't seem to find any docs
> | on the syntax of these two files. Can you send your files. Mine
> | are attached.
> |
> | No matter what I do, always the same msg in Apache errors.log. Close
> | to giving up on jk2 and planning on trying jk or mod_webapps. It
> | seems most people are not running Apache2+TC4 in-process. I would hate
> | to loose performance by going out of process, but if none of the JNI
> | modes work that I guess will be the last resort
> |
> | [rahul@PC653933 ~/<1>Apache2/logs]$ tail -f error.log
> | [Sat Feb 08 22:33:14 2003] [notice] Parent: Created child process 3380
> | [Sat Feb 08 22:33:14 2003] [error] shm.init(): No file
> | [Sat Feb 08 22:33:14 2003] [notice] Child 3380: Child process is running
> | [Sat Feb 08 22:33:17 2003] [error] shm.init(): No file
> | [Sat Feb 08 22:33:17 2003] [error] mod_jk child init 1 0
> | [Sat Feb 08 22:33:17 2003] [notice] Child 3380: Acquired the start mutex.
> | [Sat Feb 08 22:33:17 2003] [notice] Child 3380: Starting 250 worker
> threads.
> | 0 [Thread-1] INFO modeler.Registry  - Loading registry information
> | 30 [Thread-1] INFO modeler.Registry  - Creating new Registry instance
> | 812 [Thread-1] INFO modeler.Registry  - Creating MBeanServer
> | [Sat Feb 08 22:34:33 2003] [error] workerEnv.init() create slot epStat.0
> | failed
> | [Sat Feb 08 22:34:34 2003] [error] lb.service() worker failed 120000 for
> | ajp13:j
> | ni
> | [Sat Feb 08 22:34:34 2003] [error] lb.service() unrecoverable error...
> | [Sat Feb 08 22:34:34 2003] [error] mod_jk.handler() Error connecting to
> | tomcat 1
> | 20000
> |
> | Thanks,
> | Rahul.
> |
> | >From: "jcubic" <jcubic.tech@gte.net>
> | >Reply-To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> | >To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> | >Subject: RE: Help: JNI, mod_jk2 , Apache 2 not working
> | >Date: Sat, 8 Feb 2003 10:59:23 -0800
> | >
> | >I just got Apache 2.0.44 and Tomat 4.1 working with a little twist. I
> think
> | >we are trying to accomplish the same thing. I think server.xml is not the
> | >culprit. jk2.properties and worker2.properties are. Also web.xml in
> Tomcat
> | >home as well as the webapp could affect servlet and jps execution. What
> do
> | >your jk2.properties and worker2.propeties look like?
> | >
> | >My problem is that I cannot get Tomcat fired up properly from Apache
> | >without
> | >first running Tomcat manually. I keep on getting 'HTTP Status 503 -
> Servlet
> | >invoker is currently unavailable' error if I don't run Tomcat first. Of
> | >course this would defeat the purpose of using Tomcat as worker from
> Apache.
> | >
> | >My other problem is that I cannot get org/apache/jk/apr/TomcatStarter
> | >started properly unless I specify whole bunch of jar files using
> classpath
> | >in [vm:] directory. It looks like jvm that Apache runs have trouble with
> | >class path in my environment. But I don't know how to set it. I am
> | >interested in knowing how you get TomcatStarter working.
> | >
> | >Other than those 2 problems, my Apache can serve up html, jsp, as well as
> | >servlet in my webapp fine.
> | >
> | >Jimmy
> | >Redmond, Washington
> | >
> | >
> | >[jcubic]  -----Original Message-----
> | >From: Rahul Bhargava [mailto:coderobo@hotmail.com]
> | >Sent: Saturday, February 08, 2003 8:59 AM
> | >To: tomcat-user@jakarta.apache.org
> | >Subject: Help: JNI, mod_jk2 , Apache 2 not working
> | >
> | >
> | >   Re-posting with the relevant files attached.
> | >
> | >   Keep getting the error  from mod_jk2 about Error connecting to tomcat
> | >120000.
> | >
> | >   Using Apache 2.0.44 with Tomcat 4.1.18 on Win2K. Checked my config
> 1000
> | >times everything looks
> | >   good. Is this a know issue ? Is there ant doc/reference on
> | >workers2.properties ?
> | >
> | >   Attached are my config files.
> | >
> | >   [Sat Feb 08 00:14:04 2003] [notice] Parent: Created child process 3316
> | >   Apache.exe: Could not determine the server's fully qualified domain
> | >name,
> | >using
> | >   192.168.1.2 for ServerName
> | >   [Sat Feb 08 00:14:04 2003] [error] shm.init(): No file
> | >   [Sat Feb 08 00:14:04 2003] [notice] Child 3316: Child process is
> running
> | >   [Sat Feb 08 00:14:04 2003] [notice] jk2_init() Found child 3316 in
> | >scoreboard sl
> | >   ot 0
> | >   [Sat Feb 08 00:14:04 2003] [notice] vm.init(): Jni lib: C:\Program
> | >Files\Java\j2
> | >   re1.4.1_01\bin\client\jvm.dll
> | >   [Sat Feb 08 00:14:04 2003] [notice] vm.open2() done
> | >   [Sat Feb 08 00:14:04 2003] [notice] jni.validate() class=
> | >org/apache/jk/apr/Tomc
> | >   atStarter
> | >   [Sat Feb 08 00:14:04 2003] [notice] Loaded
> | >org/apache/jk/apr/TomcatStarter
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.init() setting
> | >stdout=C:/servers/Apache2
> | >   /logs/stdout.log...
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.init() setting
> | >stderr=C:/servers/Apache2
> | >   /logs/stderr.log...
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.init() ARG start
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.init() calling main()...
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.validate() class=
> | >org/apache/jk/apr/Tomc
> | >   atStarter
> | >   [Sat Feb 08 00:14:05 2003] [notice] Loaded
> | >org/apache/jk/apr/TomcatStarter
> | >   [Sat Feb 08 00:14:05 2003] [notice] jni.init() disabling the non init
> | >hook
> | >worker
> | >   [Sat Feb 08 00:14:05 2003] [error] shm.init(): No file
> | >   [Sat Feb 08 00:14:05 2003] [notice] workerEnv.init() ok
> | >C:/servers/Apache2/conf/
> | >   workers2.properties
> | >   [Sat Feb 08 00:14:06 2003] [error] mod_jk child init 1 0
> | >   [Sat Feb 08 00:14:06 2003] [notice] Child 3316: Acquired the start
> | >mutex.
> | >   [Sat Feb 08 00:14:06 2003] [notice] Child 3316: Starting 250 worker
> | >threads.
> | >   [Sat Feb 08 00:14:45 2003] [error] workerEnv.init() create slot
> epStat.0
> | >failed
> | >   [Sat Feb 08 00:14:45 2003] [error] lb.service() worker failed 120000
> for
> | >ajp13:j
> | >   ni
> | >   [Sat Feb 08 00:14:45 2003] [error] lb.service() unrecoverable error...
> | >   [Sat Feb 08 00:14:45 2003] [notice] vm.detach() ok
> | >   [Sat Feb 08 00:14:45 2003] [error] mod_jk.handler() Error connecting
> to
> | >tomcat 1
> | >   20000
> | >   [Sat Feb 08 00:14:47 2003] [notice] lb.getWorker() All workers in
> error
> | >state, u
> | >   se the one with oldest error
> | >   [Sat Feb 08 00:14:47 2003] [error] workerEnv.init() create slot
> epStat.0
> | >failed
> | >   [Sat Feb 08 00:14:47 2003] [error] lb.service() worker failed 120000
> for
> | >ajp13:j
> | >   ni
> | >   [Sat Feb 08 00:14:47 2003] [error] lb.service() unrecoverable error...
> | >   [Sat Feb 08 00:14:47 2003] [notice] vm.detach() ok
> | >   [Sat Feb 08 00:14:47 2003] [error] mod_jk.handler() Error connecting
> to
> | >tomcat 1
> | >   20000
> | >   ______________________________________________________
> | >
> | >   _________________________________
> | >   Rahul Bhargava
> |
> |
> | _________________________________________________________________
> | The new MSN 8: advanced junk mail protection and 2 months FREE*
> | http://join.msn.com/?page=features/junkmail
> |


> ----------------------------------------------------------------------------
> ----


> | ---------------------------------------------------------------------
> | To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> | For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message