tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Neumeier <brett.neume...@ualloyalty.com>
Subject RE: jk2 for apache 2.0.44 + tomcat 4.1.18
Date Thu, 06 Feb 2003 16:22:44 GMT
I am not a Tomcat developer, so this is just what I have gathered by looking
at this stuff for the last couple of days...

It appears that there are two different streams of version numbers involved
here.  If you grab the file from builds/jakarta-tomcat-connectors/, then you
are getting a particular version of the connector code, that is "JK2 version
2.0.2".

If you grab a file from builds/jakarta-tomcat-4.0/, then you're getting the
connector released as part of the Tomcat release -- so instead of getting a
particular version of the JK2 connector, you're getting "The version of JK2
released with Tomcat 4.1.18".

I opted to get the build from the jakarat-tomcat-4.0 location because I
notice that the code there is more up to date if you look at the CVS
repository.  For example, if you look at jk/native/apache-2.0/mod_jk.c you
will see that the release tagged JK2_2_0_2 is 1.60 but the release tagged as
TOMCAT_4_1_18 is 1.62.  I imagine that later code is probably better; maybe
I'm wrong.

You could also just check out from CVS and have the very latest code, of
course.

Cheers,

bn

> -----Original Message-----
> From: pqin@shareowner.com [mailto:pqin@shareowner.com]
> Sent: Thursday, February 06, 2003 9:55 AM
> To: tomcat-user@jakarta.apache.org
> Subject: RE: jk2 for apache 2.0.44 + tomcat 4.1.18
> 
> 
> I am confused. Which tarball shall I grab?
> 
> http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk2
> /release/v2.0.
> 2/
> 
> http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4
> .1.18/src/
> 
> 
> Regards,
>  
>  
> PQ
>  
> "This Guy Thinks He Knows Everything"
> "This Guy Thinks He Knows What He Is Doing"
> 
> -----Original Message-----
> From: Brett Neumeier [mailto:brett.neumeier@ualloyalty.com] 
> Sent: February 6, 2003 10:52 AM
> To: 'Tomcat Users List'
> Subject: RE: jk2 for apache 2.0.44 + tomcat 4.1.18
> 
> The jakarta-tomcat-connector source tarball is available in 
> the same place
> as the Tomcat tarball:
> 
> http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4
.1.18/src/

It does seem odd that the TC 4.1 releases are under jakarta-tomcat-4.0... I
guess it's just one of those mysteries.

Compiling mod_jk2 is not the most straightforward process -- there's a web
page with instructions that might help at
http://www.pubbitch.org/jboss/mod_jk2.html

Cheers,

bn

> -----Original Message-----
> From: pqin@shareowner.com [mailto:pqin@shareowner.com]
> Sent: Thursday, February 06, 2003 9:42 AM
> To: tomcat-user@jakarta.apache.org
> Subject: jk2 for apache 2.0.44 + tomcat 4.1.18
> 
> 
> Which tomcat-connector do I use to build mod_jk2 for Apache 
> 2.0.44 -> Tomcat
> 4.1.18? where can I download?

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message