tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NJ Rogers <nikki.rog...@bristol.ac.uk>
Subject Problem with tomcat and commons-logging.jar
Date Tue, 25 Feb 2003 13:31:21 GMT
Hi

I have tomcat-4.1.12 installed without apache, use the java j2sdk 
version 1.4.0_02 and have more than one webapp in the same tomcat 
installation.

Two of my webapps run fine, but the third - Axis - (although relatively
"happy"), causes probs when I try to connect to it from the command 
line client.
I get:
Exception in thread "main" java.lang.NoClassDefFoundError: 
org.apache.commons.lo
gging.LogFactory
        at org.apache.axis.components.logger.LogFactory.class$(LogFactory.java:8
4)
etc ..


I have searched various mailing lists & have found others with the same
problem. Although it appears initially to be a basic classpath issue, 
in fact I (as with others) have tried sticking the commons-logging.jar 
in the likely places, to no avail.

I found one poss solution on the lists, but it was a solution via 
the apache workers2.properties file. 

Does anyone know of a solution purely for tomcat?

Many thanks
Nikki

----------------------
NJ Rogers
nikki.rogers@bristol.ac.uk
Technical Researcher
(Semantic Web Applications Developer)
ILRT
Institute for Learning and Research Technology 
University of Bristol, 8-10 Berkeley Square,   BRISTOL   
BS8 1HH, UK
Tel:  ++44(0)117 928 7096 (Direct)
Tel:  ++44(0)117 928 7193 (Office)
Fax: ++44(0)117 928 7112
http://www.ilrt.bristol.ac.uk


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message