tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Hanik" <>
Subject RE: Class not being found - please help !
Date Thu, 06 Feb 2003 00:43:32 GMT
I believe your class has to belong to a package.

so if your class is wwSecurity, make sure it is in a java package.


-----Original Message-----
From: Derek Clarkson []
Sent: Wednesday, February 05, 2003 4:44 PM
Subject: Class not being found - please help !

Hi all,
	We've got tomcat 4.1 running in linux and have successfully loaded the 
postgres drivers by placing the jar file in the /var/tomcat4/common/lib 
directory and developed a site. However, I have just created a java class 
which I wish to use on the site, but every time I try to load the class in a 
JSP page I get this error :

Generated servlet error:
/var/tomcat4/work/Standalone/localhost/_/ cannot resolve 
symbol  : class wwSecurity
location: class org.apache.jsp.index_jsp

I first tried placing the class in a jar in the /var/tomcat4/common/lib/ 
directory. I then tried /var/tomcat4/shared/lib. I also tried placing the 
.class file in the classes directories of these locations and the 
WEB-INF/classes directory. Of course I restarted tomcat after each attempt.

I have not been able to get tomcat to find the class once. Can anyone help ?

Derek Clarkson
Web: http://users/bigpond/net/au/drekka

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message