tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry Isaacs" <Larry.Isa...@sas.com>
Subject RE: servlet not working on tomcat 4.1.18 - help please!!!
Date Tue, 11 Feb 2003 13:16:45 GMT
Is it a typo that "localhost:8080/intranettv" doesn't match the
case in "<url-pattern>/IntranetTV</url-pattern>"?  It needs
to in order to work.

Cheers,
Larry

> -----Original Message-----
> From: derrick.robertson@bt.com [mailto:derrick.robertson@bt.com] 
> Sent: Tuesday, February 11, 2003 8:08 AM
> To: tomcat-user@jakarta.apache.org
> Subject: servlet not working on tomcat 4.1.18 - help please!!!
> 
> 
> Im trying to migrate from tomcat 3.2.1 to tomcat 4.1.18.
> 
> Basically, Ive got the tomcat 4.1.18 to start up and the 
> localhost:8080 runs
> as do the examples such as jsp pages and servlet examples.
> 
> Ive added context to the server.xml like:
> 	<!--derrick added this line -->
> 	<Context 	path="/intranettv" 
> 			docBase="D:\internettv\admin\public_site"
> 			debug="0"
>                  	reloadable="true" 
> 			crossContext="false">
> 	</Context>
> 
> In the folder public_site, i have a Web-inf folder with a 
> web.xml in it.
> My web.xml looks like this:
> <!DOCTYPE web-app 
>     PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN" 
>     "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">
> 
> <web-app>
> 
>     <display-name>IntranetTV</display-name>
>     <description>
> 	This is the IntranetTV application with a source code 
> organization
> 	based on the recommendations of the Application 
> Developer's Guide.
>     </description>
> 
>     <servlet>
>         <servlet-name>IntranetTV</servlet-name>
>         
> <servlet-class>com.bt.intranettv.view.IntranetTV</servlet-class>
> 	<init-param>
>             <param-name>root</param-name>
>             
> <param-value>D:\intranettv\admin\public_site\</param-value>
>         </init-param>
>         <load-on-startup>-100</load-on-startup>
>     </servlet>
> 
>     <servlet-mapping>
>         <servlet-name>IntranetTV</servlet-name>
>         <url-pattern>/IntranetTV</url-pattern>
>     </servlet-mapping>
> </web-app>
> 
> My problem is that when i then go to url localhost:8080/intranettv
> the browser displays a 404 error - intranet. 
> The requested resource (/intranet) is not available.
> 
> what have I done wrong, or what can i do to put it right??
> 
> (PS I have compiled the classes with java 1.2 but the tomcat 
> is running with
> java 1.4 - will this cause any problems - it should be 
> backwards compatible)
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message