tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <JTur...@AAS.com>
Subject RE: Question about building jakarta-tomcat-connectors-4.1.18-src
Date Wed, 19 Feb 2003 18:03:44 GMT

In my opinion you will have a much easier time of it if you use configure
instead:

./configure --with-apxs=/path/to/apache/bin/apxs
make
make install

I've had all kinds of problems with ant on RH 7.2 trying to build the
connectors.  The configure method is painless.

John

> -----Original Message-----
> From: Ryan Dooley [mailto:dooleyr@missouri.edu]
> Sent: Wednesday, February 19, 2003 12:57 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Question about building jakarta-tomcat-connectors-4.1.18-src
> 
> 
> Hi,
> 
> I'm having issues building the jakarta-tomcat-connectors 
> (4.1.18) from 
> source.  The build environment is:
> 
> server platform: redhat linux 7.3
> java version: j2sdk 1.4.1_01
> ant version: 1.5
> tomcat version: 4.1.18
> 
> I've setup up the environment for JAVA_HOME, CATALINA_HOME, PATH, etc.
> 
> The errors I'm getting are:
> 
> jkjava:
>     [javac] Compiling 31 source files to 
> /usr/local/src/jakarta-tomcat-connectors-4.1.18-src/jk/build/classes
>     [javac] 
> /usr/local/src/jakarta-tomcat-connectors-4.1.18-src/jk/java/or
> g/apache/jk/common/JkInputStream.java:66: 
> package javax.servlet does not exist
>     [javac] import javax.servlet.ServletInputStream;
>     [javac]                      ^
>     [javac] 
> /usr/local/src/jakarta-tomcat-connectors-4.1.18-src/jk/java/or
> g/apache/jk/common/JkInputStream.java:67: 
> package javax.servlet.http does not exist
>     [javac] import javax.servlet.http.HttpServletRequest;
>     [javac]                           ^
>     [javac] 
> /usr/local/src/jakarta-tomcat-connectors-4.1.18-src/jk/java/or
> g/apache/jk/common/JkInputStream.java:68: 
> package javax.servlet.http does not exist
>     [javac] import javax.servlet.http.Cookie;
>     [javac]                           ^
>     [javac] Note: Some input files use or override a deprecated API.
>     [javac] Note: Recompile with -deprecation for details.
>     [javac] 3 errors
> 
> Any help would be appreciated.
> Cheers,
>     Ryan
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message