tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Problem with tomcat and commons-logging.jar
Date Tue, 25 Feb 2003 14:02:38 GMT

Try this...

set 
CLASSPATH=%CLASSPATH%;%CATALINA_HOME%\common\endorsed\xercesImpl.jar;%CATALINA_HOME%\common\endorsed\xmlParserAPIs.jar;%CATALINA_HOME%\shared\lib\jaxrpc.jar;%CATALINA_HOME%\shared\lib\saaj.jar;%CATALINA_HOME%\common\lib\log4j-1.2.8.jar;%CATALINA_HOME%\webapps\axis\WEB-INF\lib\axis.jar;%CATALINA_HOME%\webapps\axis\WEB-INF\lib\commons-discovery.jar;%CATALINA_HOME%\webapps\axis\WEB-INF\lib\commons-logging.jar;%CATALINA_HOME%\webapps\axis\WEB-INF\classes


Install web service:
D:\myclasses\servlets\axis-1_1RC1\samples\stock>
java org.apache.axis.client.AdminClient 
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd

Run web service:
D:\myclasses\servlets\axis-1_1RC1\build\classes>
java samples.stock.GetQuote 
-lhttp://localhost:8080/axis/servlet/AxisServlet -uuser1 -wpass1 XXX


You may have to modify the paths to the jars in the "set CLASSPATH", but 
this should make the point of what is required.

Jake

At 01:31 PM 2/25/2003 +0000, you wrote:
>Hi
>
>I have tomcat-4.1.12 installed without apache, use the java j2sdk
>version 1.4.0_02 and have more than one webapp in the same tomcat
>installation.
>
>Two of my webapps run fine, but the third - Axis - (although relatively
>"happy"), causes probs when I try to connect to it from the command
>line client.
>I get:
>Exception in thread "main" java.lang.NoClassDefFoundError:
>org.apache.commons.lo
>gging.LogFactory
>         at 
> org.apache.axis.components.logger.LogFactory.class$(LogFactory.java:8
>4)
>etc ..

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message