tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <>
Date Tue, 18 Feb 2003 14:12:21 GMT

First, you have an invalid context "path" of "\".  It should be either "" 
for the ROOT context or something like "/apps".  Note the forward slash 
instead of the backslash and notice that a path of "/" does *not* refer to 
the root app.  It is an undefined path according to Tomcat.  I'm not really 
sure why "" was used for the ROOT context instead of "/".  It just is, so, 
now you know.

Second, if you configure this in server.xml and then expect a .war of the 
name apps.war to be extracted to a directory of the same name (minus the 
".war"), you are mistaken.  You will need to shut down Tomcat and unpack 
this yourself first.  If you didn't configure anything in server.xml, then 
it would be unpacked like you expect.  It is all in Tomcat's 
documentation.  Don't feel alone on this one, though.  A lot of people have 
had this confusion and the behavior is somewhat of a contentious 
issue.  However, now that you know it works this way (whether we like it or 
not), you can work around it.


At 04:13 PM 2/18/2003 +0530, you wrote:
>hi all i am using tomcat 4.1.17 windows 95. i tested my application 
>keeping it in a directory "apps" on desktop and configuring the server.xml 
>file. No when i create the war file of the directory
>and place it in webapps when i restart my server the apps.war is not 
>getting extracted and teh server crashes. i used
><Context path="\" docBase="/apps"  appBase="webapps" debug="0" 
>reloadable="true" crossContext="true" privileged="true">
>any help any idea any opinion would be great
>To unsubscribe, e-mail:
>For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message