tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <>
Subject Re: Tomcat 4.1.18: Deploy Problem
Date Tue, 18 Feb 2003 14:04:44 GMT

The deploy command uses HTTP PUT and that isn't supported by browsers.  It 
is supported by the Catalina Ant tasks provided in the appdev sample in the 
Tomcat documentation.   Also, the deploy command doesn't put the .war file 
in the webapps directory when it is done uploading.  It puts it in the 
manager app's work directory.

The install command doesn't upload your file.  It runs it from where you 
specify.  Normally, I install a WAR directory structure instead of a .war 
file itself when using the install command.  I actually haven't bothered 
trying to "install" a .war file.  However, if you look at the manager app 
(at http://localhost:8080/manager/html/list ), at least with 4.1.19 and 
above, you will find an option to upload a .war file.  I believe this does 
put it into webapps like you want, but you'll have to test it for yourself.


At 11:12 AM 2/18/2003 +0100, you wrote:
>Hi everyone !
>I'm migrating from version 4.0.4 to version 4.1.18.
>The problem regarding the deploy of my application.
>I'm trying to install my application with the manager tool but it
>does'nt  work.
>The manager tool does'nt unpack WAR file into directory webapps. Why ?
>I have used the usual command :
>         http://host:port/manager/install?
>I have tried the command "deploy" but  it does'nt  work.
>  I have also tried to deploy with Web Application Manager and I have
>had the same negative result.
>I'll appreciate any idea or hint!
>  Thanks in advance
>To unsubscribe, e-mail:
>For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message