tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Guo <>
Subject RE: Manual servlet deployment problems on 4.1.18
Date Wed, 26 Feb 2003 19:21:21 GMT

>3.   I've tried referring to the servlet using the URI's:

 > localhost:8080/servlet/simple

You tried to make it simple, but actually made it complicated.
Your webapp is simple, so you should invoke the servlet by:
Naming all the same tends to confuse users (not sure confuses Tomcat or not). Why not try:
'test' for the webapp
'Simple' for the servlet
'simple' for the servlet name in web.xml
then you will invoke by
http://localhost:8080/test/servlet/Simple or
http://localhost:8080/test/servlet/simple or
Good luck.
 Steve Hole <> wrote:On Wed, 26 Feb 2003 13:12:47 -0500
"Shapira, Yoav" 

> Howdy,
> >The servlet was deployed as:
> >
> > {CATALINA_HOME}/webapps/simple
> > {CATALINA_HOME}/webapps/simple/WEB-INF/web.xml
> > {CATALINA_HOME}/webapps/simple/WEB-INF/classes/simple.class
> >The web.xml file contains (less the ---- delimiters):
> > 
> > simple
> > ca.esys.simple
> > 
> That's a mismatch. If the servlet is in package ca.esys then it should
> be under WEB-INF/clases/ca/esys/simple.class.

Actually, that is a cut and paste error in the mail message. My 
apologies. The web.xml file actually contains:


The version that I put in the earlier message was my attempt to try 
deploying under a package, which also did not work.


Steve Hole
Chief Technical Officer - Electronic Billing and Payment Systems
ACI Worldwide

Phone: 780 424 4922

To unsubscribe, e-mail:
For additional commands, e-mail:

Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, and more
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message