tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Tomcat <tom...@mobile.mp>
Subject Re: LE vs. Full
Date Mon, 03 Feb 2003 13:06:51 GMT
On Tue, 2003-02-04 at 23:21, Rick Fincher wrote:
> Type java -version from the command line where you are running the RPM to be
> sure you are getting 1.4.1.  RH 8.0 ships with a JDK 1.3.1.
> 
> JAVA_HOME doesn't have any effect on the shell, only on Tomcat.  You have to
> set your path so that the shell finds 1.4.1 before 1.3.1, so it can find all
> the 1.4.1 stuff it is looking for for the dependency checks.
> 
> Since a Tomcat install doesn't install any libraries or do anything except
> upack the files you might be able to roll your own simple RPM to install it.
> Or just write a script that unpacks Tomcat with the assumption that 1.4.1 is
> already installed.

I looked at it some more.  This is what the tomcat rpm requires:

# rpm -q -p tomcat4-4.1.18-le.1jpp.noarch.rpm -R
jaxp_parser_impl
xml-commons-apis
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh

And this is what the j2sdk rpm provides:

# rpm -q --provides j2sdk-1.4.1-fcs
j2sdk = 2000:1.4.1-fcs

It seems like Sun's Java rpm doesn't indicate that it provides
jaxp_parser_impl or xml-commons-apis, so the Tomcat rpm doesn't work.  I
tried it like this:

# rpm --install -v --nodeps tomcat4-4.1.18-le.1jpp.noarch.rpm
Preparing packages for installation...
tomcat4-4.1.18-le.1jpp
couldn't find /usr/share/java/jaxp_parser_impl.jar
make sure to have a JAXP_PARSER RPM installed and make a symlink :
ln -s /usr/share/java/jaxp_parser.jar /var/tomcat4/common/endorsed/
couldn't find /usr/share/java/xml-commons-apis.jar
make sure to have  xml-commons-apis RPM installed and make a symlink :
ln -s /usr/share/java/xml-commons-apis.jar /var/tomcat4/common/endorsed/

which forces it to install without checking dependencies.  It complains
that it wants a jaxp_parser_impl.jar and a xml-commons-apis.jar
somewhere.  However, I disregarded those complaints from it, and ran it
and it works fine.

So.... my suggestion is this: Maybe the tomcat-4-4.1.18-le.rpm should
check for j2sdk-1.4 instead of looking for jaxp_parser and xml-commons? 
If it worked that way, I could just do rpm install of the Sun j2sdk, and
then rpm install tomcat-le, and it would be done.  Otherwise, I will
just use --nodeps, but that is somewhat contrary to the idea of an rpm,
right?

Thanks!



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message