tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Harrison" <goodm...@alumni.princeton.edu>
Subject problem with Tomcat and port 8080
Date Sun, 16 Feb 2003 19:13:51 GMT
I'm running (or trying to) Tomcat 4.0.6 on RedHat 8.0 for PC. I installed Tomcat from a binary
(ie. I just unpacked it and moved it into /usr/local. I ultimately hope to run it connected
to Apache (2.0.44) through an ajp13 connector, but for now I just want the server to run by
itself on port 8080.

When I startup Tomcat, it writes an error to logs/catalina.out about a BindException: address
already in use:8080. To try to shut off whatever might be listening on 8080, I've made sure
to kill the 'java' process for Tomcat and Apache (which starts automatically when rebooting).
But I still get the same error.

Another strange thing: despite the BindException, the 'java' process keeps running. Executing
shutdown.sh produces the four "Using..." lines of output and then hangs--I have to use Ctrl-C
to get a prompt back, and the 'java' process continues to run.

Also: a bit of history. I had Tomcat working OK on 8080 a few days ago. Then I began working
to set up the connector: I complied a mod_jk and set up httpd.conf with the proper directives.
Something I did must have offended Tomcat, because it stopped responding on 8080. To get a
fresh start, I downloaded a new copy of Tomcat this morning and installed it in a separate
directory under /usr/local. It's this new copy that has been returning the BindException.

Thanks,

Michael

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message