tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wagner" <wagne...@itautec-philco.com.br>
Subject SSL Error: no cipher suites in commom
Date Tue, 11 Feb 2003 14:38:36 GMT
Hello,

I'm trying to set a SSL for Tomcat standalone... but i'm getting the error:

PoolTcpEndpoint: Handshake failed
javax.net.ssl.SSLHandshakeException: no cipher suites in common

When i try to open a SSL conection...



What i did was:

- generate a RSA request using Openssl,
- after the certificate arrived, i did the command: openssl pkcs7 -inform
PEN -in cert.p7c -print_certs to separate the CA certificate and the client
certificate,
- then i imported the CA certificate to cacerts file with:
keytool -import -alias certsign -file CA_certfile - keystore cacerts
- then i imported the client certificate with: keytool - import -alias
client -file client_certfile - keystore client.keystore
- the i edited the server.xml file with the lines:

<Http10Connector
          port="443"
          secure="true"
          keystore="C:\j2sdk1.4.1_01\jre\lib\security\client.keystore"
          keypass="client" />


Is there anything wrong???? Any misconfiguration????

I've tried to install the same certificate on apache and it worked fine.

Thanks in advance,
Wagner Garcia Campagner.

Mime
View raw message