tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: SSL cert on Apache not working properly with Tomcat?
Date Thu, 09 Jan 2003 06:24:13 GMT
This is a known problem.  See
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15456 for more details.

It has to do with the (non-existent) client cert, and has nothing to do with
the Apache cert.  Also (besides filling up log space), it's pretty harmless.

"Denise Mangano" <DeniseM@complusdata.com> wrote in message
news:5D83C44941AFD4118B6F0002B302984F43863D@EXCHANGE_SERVER...
> I'm attempting to break down each of my individual problems into separate
> posts, hoping that makes it a little easier to address each issue.
>
> This error appears in my catalina.out even though my webapp works
properly.
> Any suggestions on what would cause this error?  I checked the line
> indicated by the error and it is "byte[] certData =
certString.getBytes();"
> It appears this has to do with my security certificate which is specified
in
> my httpd.conf file.  Although my app works, I am concerned that this could
> mean a security issue and if that is the case then I need to get this
> resolved.
>
> SEVERE: Error in action code
> java.lang.NullPointerException
>         at
> org.apache.jk.server.JkCoyoteHandler.action(JkCoyoteHandler.java:386)
>         at org.apache.coyote.Response.action(Response.java:222)
>         at
>
org.apache.coyote.tomcat4.CoyoteAdapter.postParseRequest(CoyoteAdapter.java:
> 310)
>         at
> org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java:221)
>         at
> org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:261)
>         at
> org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:360)
>         at
org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:632)
>         at
>
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:590)
>         at
> org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:707)
>         at
>
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
> a:530)
>         at java.lang.Thread.run(Thread.java:536)
>
> I compared the time I got this message to other logs.  No error messages
in
> other logs, but this error gets logged at the exact same time that control
> leaves apache and I pull up my first page in my tomcat webapp.
>
> Taking the advice provided on a previous post some time back, I have not
> made any changes to Tomcat config regarding SSL.  I was told that since I
> have SSL configured on Apache, I wouldn't need to make any settings in
> Tomcat since it is not a standalone server.  Any suggestions?
>
> Thanks all!
>
> Denise
>




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message