tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Faulkner <christopher.faulk...@ntlworld.com>
Subject Re: RE: mod_jk config problems
Date Tue, 28 Jan 2003 16:40:05 GMT
>
>Check the logs...it is looking for "locahost", not "localhost".  Note the
>missing "l".
>

Ouch. I had just spotted it after sending the email - I altered it to use my hostname instead
and realised that worked.

In my defence, the mistake is on the online documentation, although I should have read it
properly ! I copied/pasted from

http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/jk/workershowto.html#A sample worker.properties

I suppose that should be fixed.

Chris

>
>Check the logs...it is looking for "locahost", not "localhost".  Note the
>missing "l".
>
>Here's the minimum required workers.properties file:
>
># BEGIN workers.properties
># Definition for Ajp13 worker
>worker.list=ajp13
>worker.ajp13.port=8009
>worker.ajp13.host=localhost
>worker.ajp13.type=ajp13
># END workers.properties
>
>John
>
>> -----Original Message-----
>> From: Chris Faulkner [mailto:christopher.faulkner@ntlworld.com]
>> Sent: Tuesday, January 28, 2003 11:21 AM
>> To: Tomcat Users List
>> Subject: mod_jk config problems
>> 
>> 
>> Hello
>> 
>> I am trying to configure mod_jk to link Apache to Tomcat 
>> which I have done before with TC 3 and 4.0. I am trying to do 
>> it with 4.1.18/Apache 1.3. There is no sample 
>> workers.properties file with 4.1.18 - is this 
>> deliberate ? Anyway, I made my own but I can't get my 
>> requests through !
>> 
>> The mod_jk log is saying this:
>> 
>> [Tue Jan 28 16:15:31 2003]  [jk_ajp_common.c (1245)]: ERROR: 
>> can't resolve tomcat address locahost
>> [Tue Jan 28 16:15:31 2003]  [jk_ajp_common.c (1247)]: ERROR: 
>> invalid host and port locahost 8009
>> [Tue Jan 28 16:15:31 2003]  [jk_worker.c (174)]: 
>> wc_create_worker validate failed for worker1
>> [Tue Jan 28 16:15:31 2003]  [jk_worker.c (244)]: 
>> build_worker_map failed to create workerworker1
>> 
>> So something is happening  with the workers - looks like a 
>> failure to resolve to localhost on port 8009. Can't think why 
>> that wouldn't work. Any ideas out there ?
>> 
>> We are on Apache 1.3 so I am not keen on using jk2 - this 
>> seems to demand recompilation of Apache 1.3. Is that correct ?
>> 
>> Apache also complained about "JkLogStampFormat" in the 
>> mod_jk.conf file. This directive is given on one of the 
>> sample pages. Anyone know why ?
>> 
>> I downloaded and installed mod_jk-1.3.... and jk_jnicb.so to 
>> my shared library directory.
>> 
>> from 
>http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.2
>/bin/linux/i386/
>
>
>Thanks
>
>Chris
>
>
>
>
>
>
>
>
>
>--
>To unsubscribe, e-mail:
><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail:
><mailto:tomcat-user-help@jakarta.apache.org>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>
>




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message