tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felicia Neff ...@panix.com>
Subject Re: Tomcat configuration problem: JSPs work, servlets don't
Date Wed, 22 Jan 2003 20:52:54 GMT
Woops, I realize that I should have been more specific.  The error I get
is a 404 error.  I'm sure the servlet itself works, because I dropped it
into the examples directory and was able to run it. -- Felicia

On Wed, 22 Jan 2003, Felicia Neff wrote:

> I am running Tomcat-4.1.18, Apache-1.3.27, and mod_jk-1.2.0.  The problem
> I am having is that while JSPs work, servlets don't.  This is the relevant
> portion of my server.xml file:
>       <Host name="www.mydomain.org" debug="0"
>        appBase="/path/to/files" liveDeploy="true"
>        unpackWARs="false" autoDeploy="true" workDir="/var/tomcat/work">
>
>         <Valve className="org.apache.catalina.valves.AccessLogValve"
>                  directory="/var/tomcat/log"  prefix="tomcat_access_log."
>                  suffix=".log"
>                  pattern="common" resolveHosts="false"/>
>
>         <!-- Tomcat Root Context -->
>           <Context path="" docBase="/path/to/files" debug="0" reloadable="true"/>
>
>       </Host>
>
> In /path/to/files, I have:
> hello.jsp
> WEB-INF/classes/HelloServlet.class
> WEB-INF/classes/HelloServlet.java
>
> >From what I have read, if I don't have a web.xml in WEB-INF, then the
> default will be used.  Since this is just for testing, I'm hoping that I
> don't need one.  The ultimate goal is to set this up for an isp. so that
> users can put their servlets into place and have them work without having
> the privileges to reload anything.
> Thanks in advance for your help. -- Felicia

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message