tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Rodak" <bro...@cmcflex.com>
Subject interesting java.lang.NullPointerException error when first viewing an index.jsp page - refresh once and page loads correctly
Date Fri, 10 Jan 2003 21:15:12 GMT
This may be a rather easy issue but with my limited knowledge of Tomcat - I
thought one of you more qualified folks would have a solution.

Whenever I visit the initial index.jsp (via index.htm as a workaround) page
I get the following server error:

java.lang.NullPointerException at
org.apache.jsp.index$jsp._jspService(index$jsp.java:75) at
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107) at
javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
and so on....

Clicking F5 or Refresh once loads the page - so you can see it is quite a
nuisance - we have implemented Apache 1.3.27 with Tomcat 4.0.6 - I have also
posted some lines of the catalina log and error logs for review below:

Catalina_Log

2003-01-09 14:48:39 Ajp13Processor[8009][7] process: invoke
java.io.IOException: Broken pipe at
java.net.SocketOutputStream.socketWrite(Native Method) at
java.net.SocketOutputStream.write(SocketOutputStream.java:91) at
org.apache.ajp.Ajp13.send(Ajp13.java:525) at
org.apache.ajp.RequestHandler.finish(RequestHandler.java:501) at
org.apache.ajp.Ajp13.finish(Ajp13.java:395) at
org.apache.ajp.tomcat4.Ajp13Response.finishResponse(Ajp13Response.java:196)
at org.apache.ajp.tomcat4.Ajp13Processor.process(Ajp13Processor.java:464) at
org.apache.ajp.tomcat4.Ajp13Processor.run(Ajp13Processor.java:551) at
java.lang.Thread.run(Thread.java:479)

Error log

2003-01-09 22:38:16 StandardWrapperValve[jsp]: Servlet.service() for servlet
jsp threw exception java.lang.NullPointerException at
org.apache.jsp.index$jsp._jspService(index$jsp.java:75) at
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107) at
javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

Any ideas on how I can remedy this issue so that the index.jsp page loads on
first "hit" would be greatly appreciated.

You can view the page in question here:
http://sitemaster.flex-internet.com/index.jsp

Thanks again for any and all help!

Brandon Rodak
Web Services
Computer Marketing Corporation
http://www.cmcflex.com & http://www.flex-internet.com



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message