tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Lagana" <roblag...@hotmail.com>
Subject Re: why doesn't tomcat see my correct keystore?
Date Thu, 09 Jan 2003 02:20:00 GMT

I solved the problem. This apparently works fine..and uses the .keystore 
that I am actually specifying in the server.xml.

See procedures below:


I created a new keystore file but this time I specified the directory to be 
saved in and not the default dir..

such as

C:\>keytool -genkey -alias myalias -keyalg RSA -keystore c:\.mykeystore
Enter keystore password:  password

server.xml config as such:

<!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->

    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
               port="443" minProcessors="5" maxProcessors="75"
               enableLookups="true"
	       acceptCount="100" debug="0" scheme="https" secure="true"
               useURIValidationHack="false" disableUploadTimeout="true">
      <Factory 
className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory"
               clientAuth="false" protocol="TLS"
	       keystoreFile="C:\.mykeystore" keystorePass="password" />
    </Connector>

_________________________________________________________________
Protect your PC - get McAfee.com VirusScan Online 
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message