tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Priest <Robert.Pri...@bentley.com>
Subject Problem with JavaService.exe\Tomcat.exe
Date Fri, 24 Jan 2003 19:45:20 GMT
Hello,

I was wondering if anyone had any experience with the JavaService.exe aka
Tomcat.exe.

I am having a problem where it appears that the Environment PATH variable is
not being set properly in 
the JVM when tomcat.exe kicks it off.

I have a Realm implementation which loads a dll through a System.LoadLibrary
call, but I am 
running into an 

"java.lang.UnsatisfiedLinkError: no dmswebserver in java.library.path"



Now I can explicitly set the path by adding a "JVM Option" for the
"java.library.path" in the registry, but previously it would read the "Path"
registry entry without any problems. Does anyone have a clue as to why this
would stop working?


it does look like the:
	 (SetEnvironmentVariable("PATH", currentPath) 

is being called properly, but Java does not get the PATH right or something.


This is a version of the exe that I have compiled myself. Am I missing
anything in the Compiliation?


The version of Tomcat I am running is 4.1.7.
Java Version:  1.4.1_01
Visual C++: 6.0




I realize that JavaService.exe is separately maintained but I wonder if
anyone has any idea here.

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message