tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raible, Matt" <Matt_Rai...@cable.comcast.com>
Subject RE: Classes not being found in app's WEB-INF directory.
Date Fri, 17 Jan 2003 17:08:12 GMT
Use Ant to build everything - and tell it where you want your compiled
classes to end up.

-----Original Message-----
From: Erik Price [mailto:eprice@ptc.com]
Sent: Friday, January 17, 2003 10:07 AM
To: Tomcat Users List
Subject: Re: Classes not being found in app's WEB-INF directory.




Lior Shliechkorn wrote:
> I had a bunch of problems with that until I packaged the classes and then
it had no problem finding the class files. Give that a try.

I too made the mistake of putting all of my classes directly under 
WEB-INF/classes.  Now I would like to put them into a proper package, 
but cannot -- CVS knows the directory structure that I have now, and if 
I move the classes into a new directory structure (the package directory 
structure "com/ptc/appname") then CVS will get all gorked up.

Does anyone have advice for this scenario?  Surely I must not be the 
first person who needed to rearrange directories for a webapp using CVS...


Erik


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message