tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lajos <lm...@galatea.com>
Subject Re: mod_jk2 connector module not working (?)
Date Sat, 01 Feb 2003 05:48:20 GMT
Right, and also make sure your have an [shm:] block in 
workers2.properties otherwise jk2 can't start correctly.

Regards,

Lajos


Hannes Schmidt wrote:
> Looks like your
> 
> /usr/local/apache2/conf/workers2.properties
> 
> is missing. Even if Apache is not installed in one directory (as is the case
> in my Linux distribution), JK2 insists on it to be in ServerRoot\conf. Your
> ServerRoot seems to be set to /usr/local/apache2. Check out this link:
> 
> http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/jk2/confighowto.html
> 
> Trevor Hurst wrote:
> 
>>Okay, now that I successfully built the connectors
>>and have installed them. The JSP and servlets are
>>not working so, I'm almost there but not quite yet..
>>
>>Are these errors in the error_log file of any significance?
>>
>>[Fri Jan 31 14:47:04 2003] [warn] RSA server certificate is a CA
>>certificate (BasicConstraints: CA == TRUE !?)
>>[Fri Jan 31 14:47:04 2003] [error] config.update(): Can't find config
>>file /usr/local/apache2/conf/workers2.properties
>>[Fri Jan 31 14:47:04 2003] [error] shm.init(): No file
>>[Fri Jan 31 14:47:05 2003] [warn] RSA server certificate is a CA
>>certificate (BasicConstraints: CA == TRUE !?)
>>[Fri Jan 31 14:47:05 2003] [error] jk2_init() Can't find child 630400
>>in scoreboard
>>[Fri Jan 31 14:47:05 2003] [error] shm.init(): No file
>>[Fri Jan 31 14:47:05 2003] [error] mod_jk child init 1 -2
>>[Fri Jan 31 14:47:05 2003] [error] shm.init(): No file
>>[Fri Jan 31 14:47:05 2003] [error] mod_jk child init 1 0
>>[Fri Jan 31 14:47:05 2003] [error] shm.init(): No file
>>[Fri Jan 31 14:47:05 2003] [error] shm.init(): No file
>>[Fri Jan 31 14:47:05 2003] [notice] Apache/2.0.44 (Unix)
>>mod_jk2/2.0.3-dev mod_ssl/2.0.44 OpenSSL/0.9.6g configured -- resuming
>>normal operations
>>
>>
>>..looks like shared memory init function call is not working properly?
>>
>>And are the mod_jk and jk2_init init messages bad?
>>
>>Thanks for all the help!
>>
>>Cheers,
>>
>>-- Trev
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


-- 



                    Lajos Moczar
       ----------------------------------------
     Open Source Support, Consulting and Training
       ----------------------------------------
             Cocoon Developer's Handbook
  (www.amazon.com/exec/obidos/tg/detail/-/0672322579)

                    _      _____
                   / \         /
                  /___\      /
                 /     \   /____

      http://www.galatea.com -- powered by AzSSL


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message