tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lajos Moczar <lm...@galatea.com>
Subject Re: mod_jk apache2 tomcat4.1.8
Date Thu, 16 Jan 2003 18:00:19 GMT
Bill -

I read your original email again this morning, and I see I 
mis-understoond. I thought you had all those JkMount's in httpd.conf - I 
didn't see the "mod_jk.conf" comment.

What did you do to get it to work? For your performance problem, I'd 
guess it has something to do with your network - maybe you have to do a 
traceroute to see where your packets are going.

Regards,

Lajos


Bill wrote:
> Lajos
> 
> Hmmm...could you explain this more thoroughly?  The virtual hosts you
> mention are defined in the mod_jk.conf file.  I dont understand how I
> could removed that include.  It is also the only place that has JkMount
> directives...
> 
> You also mention I dont need it since I have my own LoadModule
> directive, but ApacheConfig doesnt seem to add this to the mod_jk.conf
> file, so now I am confused. :)
> 
> thx
> 
> -b
> 
> On Thu, 2003-01-16 at 03:32, Lajos Moczar wrote:
> 
>>Bill -
>>
>>Another thing is that you are mixing apples and oranges to use the 
>>auto-generated mod_jk.conf. It may not be in fact your problem, but just 
>>take the Include out of httpd.conf - you don't need it since a) you have 
>>your own LoadModule/AddModule commands; b) you are using VirtualHosts.
>>
>>Regards,
>>
>>Lajos
>>
>>
>>Kevin Kovach wrote:
>>
>>>I'm not sure what the difference is but the sample workers.proerties 
>>>file here: 
>>>http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/jk/workershowto.html 
>>>has a mixture of 'worker' & 'workers'. Is that incorrect?
>>>
>>>- Kevin
>>>
>>>Denise Mangano wrote:
>>>
>>>
>>>>Not sure if this is related to your problem since 1) I am a newbie and 
>>>>2) I
>>>>didn't see any error message included, but shouldn't the first line of 
>>>>your
>>>>workers.properties file look like:
>>>>
>>>>worker.list=ajp13
>>>>not
>>>>workers.list=ajp13
>>>>??
>>>>
>>>>(Just taking a guess but I compared it to mine).
>>>>
>>>>HTH
>>>>
>>>>Denise Mangano
>>>>Help Desk Analyst
>>>>Complus Data Innovations, Inc.
>>>>
>>>>
>>>>-----Original Message-----
>>>>From: Bill [mailto:bhalpin@collaborativefusion.com] Sent: Wednesday, 
>>>>January 15, 2003 10:35 AM
>>>>To: tomcat user
>>>>Subject: mod_jk apache2 tomcat4.1.8
>>>>
>>>>
>>>>I'm still having problems using mod_jk with Apache2.  The "unable to open
>>>>config" error seems to have gone away, the incomplete read errors are 
>>>>still
>>>>there.  I started fresh on a new box so I'll re-submit the relevant info:
>>>>
>>>>##http.conf##
>>>>
>>>>LoadModule              jk_module       modules/mod_jk.so
>>>>JkWorkersFile           /usr/local/tomcat/conf/jk/workers.properties
>>>>JkLogFile               /usr/local/apache2/logs/mod_jk.log
>>>>JkLogLevel              error
>>>>JkLogStampFormat        "[%a %b %d %H: %M: %S: %Y] "
>>>>
>>>>
>>>>Include /usr/local/tomcat/conf/auto/mod_jk.conf
>>>>
>>>>##mod_jk.conf
>>>>
>>>><VirtualHost 192.168.1.13>
>>>>   ServerName 192.168.1.13
>>>>
>>>>   JkMount /examples ajp13
>>>>   JkMount /examples/* ajp13
>>>>
>>>>   JkMount /webdav ajp13
>>>>   JkMount /webdav/* ajp13
>>>>
>>>>   JkMount /tomcat-docs ajp13
>>>>   JkMount /tomcat-docs/* ajp13
>>>>
>>>>   JkMount /manager ajp13
>>>>   JkMount /manager/* ajp13
>>>>
>>>>   JkMount /admin ajp13
>>>>   JkMount /admin/* ajp13
>>>>      JkMount /cores ajp13
>>>>   JkMount /cores/* ajp13
>>>>
>>>>   JkMount /mrccores ajp13
>>>>   JkMount /mrccores/* ajp13
>>>></VirtualHost>
>>>>
>>>>##workers.properties##
>>>>
>>>>workers.list=ajp13
>>>>worker.ajp13.type=ajp13
>>>>worker.ajp13.host=192.168.1.13
>>>>worker.ajp13.port=8009
>>>>
>>>>worker.ajp13.cachesize=10
>>>>worker.ajp13.cache_timeout=600
>>>>worker.ajp13.socket_keepalive=1
>>>>worker.ajp13.socket_timeout=300
>>>>
>>>>##server.xml##
>>>><Server port="8005" shutdown="SHUTDOWN" debug="0">
>>>>
>>>> <Listener className="org.apache.catalina.mbeans.ServerLifecycleListener"
>>>>           debug="0"/>
>>>> <Listener
>>>>className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
>>>>           debug="0"/>
>>>>
>>>> <!-- Global JNDI resources -->
>>>> <GlobalNamingResources>
>>>>
>>>>   <!-- Test entry for demonstration purposes -->
>>>>   <Environment name="simpleValue" type="java.lang.Integer" value="30"/>
>>>>
>>>>   <!-- Editable user database that can also be used by
>>>>        UserDatabaseRealm to authenticate users -->
>>>>   <Resource name="UserDatabase" auth="Container"
>>>>             type="org.apache.catalina.UserDatabase"
>>>>      description="User database that can be updated and saved">
>>>>   </Resource>
>>>>    <ResourceParams name="UserDatabase">
>>>>     <parameter>
>>>>       <name>factory</name>
>>>>      <value>org.apache.catalina.users.MemoryUserDatabaseFactory</value>
>>>>     </parameter>
>>>>     <parameter>
>>>>       <name>pathname</name>
>>>>       <value>conf/tomcat-users.xml</value>
>>>>     </parameter>
>>>>   </ResourceParams>
>>>>
>>>> </GlobalNamingResources>
>>>>
>>>><Service name="Tomcat-Apache">
>>>>
>>>>   <Connector className="org.apache.ajp.tomcat4.Ajp13Connector"
>>>>acceptCount="10" debug="0"/>
>>>>   <Engine name="Apache" defaultHost="192.168.1.13" appBase="webapps"
>>>>              debug="0">
>>>>
>>>>     <Logger className="org.apache.catalina.logger.FileLogger"
>>>>             prefix="apache_log." suffix=".txt"
>>>>             timestamp="true"/>
>>>>
>>>>     <Realm className="org.apache.catalina.realm.MemoryRealm" />
>>>>     <Host name="192.168.1.13" debug="0" appBase="webapps"
>>>>unpackWARs="true">
>>>>       <Listener className="org.apache.ajp.tomcat4.config.ApacheConfig"
>>>>               append="true" />
>>>>       <Valve className="org.apache.catalina.valves.AccessLogValve"
>>>>               directory="logs" prefix="host_access_log." suffix=".txt"
>>>>               pattern="common" />
>>>>       <Context path="" docBase="ROOT" reloadable="true" debug="0"/>
>>>>
>>>>       <Context path="/cores" docBase="mrccores" reloadable="true"
>>>>debug="0"/>
>>>>   </Host>
>>>>   </Engine>
>>>>
>>>> </Service>
>>>>
>>>></Server>
>>>>
>>>>The only error I'm getting is this in :
>>>>
>>>>
>>>>
>>>>
>>>>-- 
>>>>To unsubscribe, e-mail:
>>>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>>>For additional commands, e-mail:
>>>><mailto:tomcat-user-help@jakarta.apache.org>
>>>>
>>>>-- 
>>>>To unsubscribe, e-mail:   
>>>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>>>For additional commands, e-mail: 
>>>><mailto:tomcat-user-help@jakarta.apache.org>
>>>>
>>>> 
>>>>
>>>
>>>
>>>-- 
>>>To unsubscribe, e-mail:   
>>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>>For additional commands, e-mail: 
>>><mailto:tomcat-user-help@jakarta.apache.org>
>>>
>>>
>>
>>-- 
>>
>>
>>
>>                    Lajos Moczar
>>       ----------------------------------------
>>     Open Source Support, Consulting and Training
>>
>>                    _      _____
>>                   / \         /
>>                  /___\      /
>>                 /     \   /____
>>
>>      http://www.galatea.com -- powered by AzSSL
>>
>>
>>--
>>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>>
> 
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
> 
> 


-- 



                    Lajos Moczar
       ----------------------------------------
     Open Source Support, Consulting and Training

                    _      _____
                   / \         /
                  /___\      /
                 /     \   /____

      http://www.galatea.com -- powered by AzSSL


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message