tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Etienne Deleflie <etienne.delef...@proxima-tech.com>
Subject mod_webapp causes 2 instances of the one webapp
Date Mon, 13 Jan 2003 03:22:37 GMT
Hello,

I am using mod_webapp to connect Apache 2.0.43 to Tomcat 4.0.1

Problem is that both Tomcat AND Apache each cause an instance of the 
same webapp. So the one webapp is instantiated twice (this breaks all 
sorts of socket stuff we have in our webapp)

there is a reference to this problem (in the tomcat-dev archives) here:
http://w6.metronet.com/~wjm/tomcat/2001/Oct/msg00792.html

... but I cant work out how to change my config to make sure that only 1 
  instance of the webapp is created.

can anyone help ?

below is my server.xml, and my httpd.conf

--------------------------------------------------------
server.xml:

[snip]

   <Service name="Tomcat-Apache">

     <Connector className="org.apache.catalina.connector.warp.WarpConnector"
      port="8008" minProcessors="5" maxProcessors="75"
      enableLookups="true"
      acceptCount="10" debug="0"/>

     <Engine className="org.apache.catalina.connector.warp.WarpEngine"
      name="Apache" debug="0" appBase="webapps">

       <Logger className="org.apache.catalina.logger.FileLogger"
               prefix="apache_log." suffix=".txt"
               timestamp="true"/>

       <Realm className="org.apache.catalina.realm.MemoryRealm" />

     </Engine>

   </Service>

[snip]
--------------------------------------------------------
httpd.conf:

[snip]

<IfModule mod_webapp.c>
	WebAppConnection conn warp xenakis:8008
	WebAppDeploy myWebapp conn /plug/
	WebAppInfo info
</IfModule>

[snip]

-------------------------------------

any help is appreciated

etienne



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message