tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nihita Goel <nih...@tifr.res.in>
Subject HTTP Error 404 with Tomcat 4.1.18
Date Sat, 11 Jan 2003 07:17:11 GMT
Hi,

Would be grateful if anyone could help.

It is something basic  but I have been trying and there's no help ...

I have installed TomCat 4.1.18 over RH Linux and am able to run
succesfully but for a problem I am facing in deploying my own
application.

As given in the documentation I have created a directory myapp under
$CATALINA_HOME/web-apps/

With-in myapps is WEB-INF/classes where I have copied by
HelloServlet.class file. According to the documentation on giving
http://localhost:8080/myapp/servlet/HelloServlet in browser I should be
able to run my servlet but I get the error HTTP Error 404 : cannot find
resource.  If I copy the same to example/WEB-INF/classes it works.. What
is the problem? I also tried creating web.xml in WEB-INF directory but
still I get the same error..

Do I need to add /change anything in server.xml file ?

Also I tried copying the index.jsp from ROOT to myapps and then if I
give localhost:8080/myapps/index.jsp it runs ...

Pl help

N.G



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message