tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "PELOQUIN,JEFFREY (HP-Boise,ex1)" <jeffrey.peloq...@hp.com>
Subject RE: tomcat mod_jk issue
Date Tue, 28 Jan 2003 18:22:36 GMT
try changing 
worker.ajp13.host=www.mytest.com

to
worker.ajp13.host=localhost

sometimes this helps, sometimes it doesn't

-----Original Message-----
From: vivek karkun [mailto:vivi74@rocketmail.com]
Sent: Tuesday, January 28, 2003 11:19 AM
To: tomcat-user@jakarta.apache.org
Subject: tomcat mod_jk issue


Hello everyone,

I am having a problem with stronghold(apache 1.3) and
tomcat 4.1.18 using the mod_jk module on solaris 8.
Here are the modification i did to folowing
configuration files. Any help would be appreciated.

httpd.conf:

LoadModule    jk_module 
modules/libexec/mod_jk-1.3-eapi.so
AddModule     mod_jk.c

<IfModule mod_jk.c>
JkWorkersFile
/opt/jakarta-tomcat-4.1.18/conf/workers.properties
JkLogFile     /main/webRoot/stronghold/logs/mod_jk.log
JkLogLevel    info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkMount /*.jsp ajp13
JkMount /*/servlet/ ajp13
</IfModule>


workers.properties:

workers.tomcat_home=/opt/jakarta-tomcat-4.1.18
workers.java_home=/opt/j2sdk1.4.1_01
ps=/
worker.list=ajp13

worker.ajp13.port=8009
worker.ajp13.host=www.mytest.com
worker.ajp13.type=ajp13

Here are the following log files

mod_jk.log:

[Mon Jan 27 16:57:51 2003]  [jk_ajp_common.c (874)]:
Error connecting to the Tomcat process.
[Mon Jan 27 16:57:51 2003]  [jk_ajp_common.c (1190)]:
sending request to tomcat failed in send loop. err=2
[Mon Jan 27 16:57:51 2003]  [jk_ajp_common.c (1198)]:
Error connecting to tomcat. Tomcat is probably not
started
or is listenning on the wrong port. Failed errno = 145

server.xml:

i enabled the the ajp1.3 protocol for mod_jk module,
and i changed all localhost settings to www.mytest.com


Also when i see the ports, 8009 is running, i dont
know why apache wouldnt talk to tomcat. The amazing
part is everything works if i access the site thorugh
tomcat alone(http://www.mytest.com:8080/index.jsp),
but nothing shows up using
(http://www.mytest.com/index.jsp)

Am i missing anything here. Thanks in advance for any
help

vic

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message